Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

tabs loading and edge pushing

  • 13 replies
  • 1 has this problem
  • 42 views
  • Last reply by jscher2000

more options

This happened when i was opening an attachment in outlook 365

Attached screenshots

All Replies (13)

more options

Further to my original post, i didn`t explain the problem well enough. So, if it`s ok the following is in full, i hope. Occassionally when i`m using Outlook 365, numerous Firefox icons will run along the taskbar and vertically, and it`s quite difficult to stop and get rid of them, and most times i have to turn the computer off to start again. On the page it loads is "Try Microsoft Edge" and "Self help topics". Has anyone had this annoying problem please? see attached

more options

The problem of Firefox opening tons of windows or tabs usually is caused by opening a file that Firefox can't handle, but which Firefox was instructed to handle. Could you take a look at this article and see whether there might be a problem in the Application settings:

Firefox repeatedly opens empty tabs or windows after you click on a link

more options

jscher2000 said

The problem of Firefox opening tons of windows or tabs usually is caused by opening a file that Firefox can't handle, but which Firefox was instructed to handle. Could you take a look at this article and see whether there might be a problem in the Application settings: Firefox repeatedly opens empty tabs or windows after you click on a link

In the tabs pages it`s help topic and Microsoft Edge not empty. I will have a look at the article.

more options

jscher2000 said

The problem of Firefox opening tons of windows or tabs usually is caused by opening a file that Firefox can't handle, but which Firefox was instructed to handle. Could you take a look at this article and see whether there might be a problem in the Application settings: Firefox repeatedly opens empty tabs or windows after you click on a link </bl<em>jscher2000 said
The problem of Firefox opening tons of windows or tabs usually is caused by opening a file that Firefox can't handle, but which Firefox was instructed to handle. Could you take a look at this article and see whether there might be a problem in the Application settings: Firefox repeatedly opens empty tabs or windows after you click on a link

I looked at the article. This doesn`t happen all the time but is a nuisance. It happens randomly only when i use Outlook 365 click on new email, or other in Outlook, really when i use Outlook. The cursor will stay where it is and flicker and numerous Firefox icons will load in the taskbar and in the pages is try Microsoft Edge "top help topics" attached., and are difficult to remove It doesn`t happen when i open Firefox 62 i have resrart or shutdown to get going again. So resetting Firefox doesn`t seem to be an answer. I appreciate your concern.

more options

Okay, I thought the problem was with attachments (i.e., files you don't normally open in a browser). Now it sounds like the problem is a link or button for a function that should run in Firefox, but somehow gets "stuck" and repeats, and somehow loads that strange help page. I haven't heard of that before.

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Tracking Protection feature and extensions that counter ads and tracking may break websites that weren't built to operate normally without the blocked components.

Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: What happened to Tracking Protection?.

Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.


https://support.kaspersky.com/viruses/utility

more options

jscher2000 said

Okay, I thought the problem was with attachments (i.e., files you don't normally open in a browser). Now it sounds like the problem is a link or button for a function that should run in Firefox, but somehow gets "stuck" and repeats, and somehow loads that strange help page. I haven't heard of that before. If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally: Double-check content blockers: Firefox's Tracking Protection feature and extensions that counter ads and tracking may break websites that weren't built to operate normally without the blocked components. Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: What happened to Tracking Protection?. Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site. Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: How to clear the Firefox cache If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:
  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button
In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Then try reloading the page. Does that help? Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) If Firefox is running: You can restart Firefox in Safe Mode using either:
  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled
and OK the restart. Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh). Any improvement?

Sorry i mislead you in my original post. This problem happens when i open Outlook 365 and go to almost anywhere. I will have to take time to go through what you said. Co-rel mentioned Malwarebytes, i have Premium and it scans daily and also i do extra scans, no problems.

more options

cor-el said

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure you update each program to get the latest version of their databases before doing a scan. You can also do a check for a rootkit infection with TDSSKiller.
https://support.kaspersky.com/viruses/utility

Thank you Co-rel, i have Malwarebytes Premium for many years which scans daily and i do extra scans, no problem.

more options

Originally i thought it was only using Outlook 365 starting multiple windows but, this morning multiple windows of Firefox opened when i opened Firefox 62. It is so difficult to close all those windows and i have to shut down my computer to get rid of it. Any more knowledge please, it is most annoying.

Modified by Terry

more options

Hi Terry, does the problem occur if you start Firefox in its Safe Mode? You might try a half dozen times to see whether it occurs even once, then try start up normally again.

more options

If you "kill" Firefox to get rid of an unwanted tab/window, Firefox's post-crash session restore can bring it back, causing a cycle of frustration. I don't think there is a handy bypass, but you have two options:

To avoid an unwanted session recovery, you could either modify a settings file or hide your session history files from Firefox so that it can't restore the unwanted page at the next startup. Here's how:

Step #1: Open the profile folder

Windows

Type or paste the following into the Windows Run dialog or the system search box, and press Enter to launch Windows Explorer into this folder:

%APPDATA%\Mozilla\Firefox\Profiles

You should see at least one semi-randomly-named profile folder there. (If you see more than one, you'll want to figure out which one has the unwanted session history in it by checking each one.)

Double-click into the profile folder.

Mac or Linux

Your Firefox profile folder would be accessible in a different way than on Windows. Please see these articles for information on how to locate it:

Step #2: Your Choice of...

Modifying a Settings File

At startup, Firefox will check whether to restore tabs automatically or show you a list so you can make your own selections. In the most recent versions of Firefox, you may need to click a button to see the list.

In your profile folder, locate the file named prefs.js and open it in a text editor -- if you are running Windows, make sure to right-click > Edit or right-click > Open With to avoid executing the script.

By default, Windows hides the .js extension, so to make sure it's the right file, you may want to set Windows to show all extensions. See: https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

Paste this on a new line at the end and save the change:

user_pref("browser.sessionstore.max_resumed_crashes", 0);

When you save, make sure to avoid adding any formatting (save using a plain text format) or changing the file name (you don't want to end up with .txt on the end).

If you're not sure it worked, you could also do the next option.

Hiding Session History Files

This is less convenient if you want to restore some of your tabs, but if you don't care, you may prefer this.

  • Right-click the sessionstore-backups folder and rename it to sessionstore-backupsOLD (later you can mine the files in this folder for any important tabs you want to restore)
  • Check for any files with these names and:
    • sessionstore.jsonlz4 - created by Firefox 56-63 when it shuts down normally - rename to sessionstoreOLD.jsonlz4
    • sessionstore.js - created by Firefox 55 and earlier when it shuts down normally - rename to sessionstoreOLD.js
    • sessionstore.bak - obsolete file from years ago - delete

When you start Firefox up again, it should just show the home page.

Success?

If you need to read the contents of any of those hidden files, you can use this tool on my websites to extract out a list of the tabs:

https://www.jeffersonscher.com/ffu/scrounger.html

more options

jscher2000 said

Hi Terry, does the problem occur if you start Firefox in its Safe Mode? You might try a half dozen times to see whether it occurs even once, then try start up normally again.

This problem may not occur for a long time or maybe a couple of days, so safe mode would have to be extended if possible. How do my computer put in safe mode, and also have there for extended.

more options

Microsoft has documentation on how to put Windows in its Safe Mode, but that will usually disable your security software, so I'm not sure you should run in Windows Safe Mode (with Networking) other than for brief testing.