X
Tap here to go to the mobile version of the site.

Support Forum

Firefox address bar does not work correctly

Posted

Hello, I'm in Italy on a Windows 7 pc (no proxy). When I use the address bar to perform a search on Firefox, I'm directed to google.com instead of google.it and this shows the results of foreign sites. For example, if I write "Amazon" in the Firefox address bar, I see the results of Amazon.com and not Amazon.it. Or if I write "pizza" I get out the international results and not those in Italian. Is there a way to correct this problem? If it does not exist, unfortunately I have to switch to Chrome which works well even when working on the address bar. In the link below the screenshots of the pages opened on Firefox and on Chrome: https://imgur.com/a/o9tVNzA

Hello, I'm in Italy on a Windows 7 pc (no proxy). When I use the address bar to perform a search on Firefox, I'm directed to google.com instead of google.it and this shows the results of foreign sites. For example, if I write "Amazon" in the Firefox address bar, I see the results of Amazon.com and not Amazon.it. Or if I write "pizza" I get out the international results and not those in Italian. Is there a way to correct this problem? If it does not exist, unfortunately I have to switch to Chrome which works well even when working on the address bar. In the link below the screenshots of the pages opened on Firefox and on Chrome: https://imgur.com/a/o9tVNzA

Additional System Details

Installed Plug-ins

  • Shockwave Flash 31.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

More Information

AnnaSycamore 8 solutions 95 answers

Hello, Try to clear cache and history with forget button or try to restart Firefox in Safe Mode. https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Or if you are comfortable with command line Press Windows key+R and in the Open box paste firefox.exe -safe-mode

Another idea In the past you have activated an add-on like this? https://addons.mozilla.org/en-US/firefox/addon/always-com-googlecom-in-englis/?src=search This simply add another option for search engines Go to the Menu > Option > Search> and in One click Search Engine click restore Default Search Engines. Verify your extensions It's possible that one of them be responsible for this redirection... Hope this help

Hello, Try to clear cache and history with forget button or try to restart Firefox in Safe Mode. https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Or if you are comfortable with command line Press Windows key+R and in the Open box paste firefox.exe -safe-mode Another idea In the past you have activated an add-on like this? https://addons.mozilla.org/en-US/firefox/addon/always-com-googlecom-in-englis/?src=search This simply add another option for search engines Go to the Menu > Option > Search> and in One click Search Engine click restore Default Search Engines. Verify your extensions It's possible that one of them be responsible for this redirection... Hope this help