Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is localized Firefox versions still hardcoded to Google.com?

  • 5 replies
  • 2 have this problem
  • 19 views
  • Last reply by McCoy

more options

Scenario: using the default Google search from the address bar sends the query to Google.com instead of the user's localized Google.

This is a problem because the tools menu on Google.com does not include the country selector which allows a user to display local only results. For anyone, which is pretty much anyone outside of the US, this is an extremely useful feature for using Google and filtering results.

Currently the only solution I have found to fix this problem is to edit the google.xml file inside omni.ja file by changing the following line:

<Url type="text/html" method="GET" template="https://www.google.com/search" rel="searchform">

to:

<Url type="text/html" method="GET" template="https://www.google.co.za/search" rel="searchform">

However, this solution is less than ideal because because I will have to re-apply the change every time Firefox replaces omni.ja when it updates to a newer version. I have tried using addons to fix this problem, but I had issues in that either suggestions didn't work or the results defaulted to local results only.

Every other browser under the sun correctly redirects search terms to the country specific Google, so it would be great if Mozilla could join the party and fix an issue that has been plaguing Firefox for as long as I can remember.

Attached screenshots

All Replies (5)

more options

Hello Xiphan,

Would you go here please :

https://www.google.com/preferences?hl=en&fg=1

Scroll down to "Region Settings" and click your region.

Then click "Save" at the bottom of the page.

Does that work for you  ?

more options

McCoy said

Hello Xiphan, Would you go here please : https://www.google.com/preferences?hl=en&fg=1 Scroll down to "Region Settings" and click your region. Then click "Save" at the bottom of the page. Does that work for you  ?

No, this doesn't work. It still defaults to google.com.

more options

Would you try this please :

When you're on the Google page, click on the 'i' in a circle, next to the padlock at the left side of the address bar. That will take you to "Page Info". Then click on the little black arrow on the dropdown and then on "More Information". Click on the 'Permissions" tab and scroll down to "Access Your Location". Uncheck "Use Default" and check "Allow".

'Hope that works .....

more options

McCoy said

Would you try this please : When you're on the Google page, click on the 'i' in a circle, next to the padlock at the left side of the address bar. That will take you to "Page Info". Then click on the little black arrow on the dropdown and then on "More Information". Click on the 'Permissions" tab and scroll down to "Access Your Location". Uncheck "Use Default" and check "Allow". 'Hope that works .....

No, there is nothing you can change in or around Google that will get it to use something other than google.com because the default built-in Google search is hardcoded in the omni.ja file to send search queries to google.com.

As I have said I managed a workaround for this issue by modifying the omni.ja file, but it would be nice if Mozilla could correctly use the right Google search for the corresponding country their browser is being used in.

more options

Xiphan said

Every other browser under the sun correctly redirects search terms to the country specific Google,

With the settings, mentioned in my previous posts, I get the correct search results in three different browsers, including Firefox - I'm beginning to think that I'm totally misconstruing what you're saying (in which case : my apologies).

Would this be an option for you :

https://mycroftproject.com/google-search-plugins.html  ?