X
Tap here to go to the mobile version of the site.

Support Forum

Preferences not displaying properly

Posted

Attached image happens with latest version 62.0.2 (64-bit) also with 62.0.

After around 30s the preferences page loads correctly.

Attached image happens with latest version 62.0.2 (64-bit) also with 62.0. After around 30s the preferences page loads correctly.
Attached screenshots

Modified by megawhite

Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

More Information

Question owner

Cannot seem to attach image to the original post. I click edit post and added an image, then save, then it does not appear.

Cannot seem to attach image to the original post. I click edit post and added an image, then save, then it does not appear.
Was this helpful to you?
Quote
FFus3r
  • Top 10 Contributor
50 solutions 757 answers

Hello,

The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.
Hello, The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information. '''''Note:''' When you use this feature, you will lose any extensions, toolbar customizations, and some preferences.'' See the [[Refresh Firefox - reset add-ons and settings]] article for more information. To Refresh Firefox: # Open the Troubleshooting Information page using one of these methods: #*Click the menu button [[Image:New Fx Menu]], click help [[Image:Help-29]] and select ''Troubleshooting Information''. A new tab containing your troubleshooting information should open. #*If you're unable to access the Help menu, type '''about:support''' in your address bar to bring up the Troubleshooting Information page. #At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it. #Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported. #Click Finish and Firefox will reopen.
Was this helpful to you?
Quote

Question owner

Thanks, but I've only recently installed it for the first time and not installed any add ons etc. I think something is broken to be causing this.

After a while the page does actually fully load and operate correctly.

Thanks, but I've only recently installed it for the first time and not installed any add ons etc. I think something is broken to be causing this. After a while the page does actually fully load and operate correctly.
Was this helpful to you?
Quote
FFus3r
  • Top 10 Contributor
50 solutions 757 answers

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps: '''In Firefox 54 and below:''' # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''Advanced'' panel and the ''General'' tab. # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. '''In Firefox 55 and above''': # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''General'' panel. # Under '''Performance''', uncheck ''Use recommended performance settings''. Additional settings will be displayed. #;[[Image:Fx55Performance-disableHWA|width=500]] # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]]
Was this helpful to you?
Quote

Question owner

Hi some more info on this issue, while the preferences are half loaded as per screenshot, one of my CPU cores is 100% for about 30s before it fully loads.

Clearly something is being processed on the UI thread and blocking, thus preventing a full paint of the preferences page.

Next time it does it, I will attempt to use the FF web debug tools to see where it's locking up.

Hi some more info on this issue, while the preferences are half loaded as per screenshot, one of my CPU cores is 100% for about 30s before it fully loads. Clearly something is being processed on the UI thread and blocking, thus preventing a full paint of the preferences page. Next time it does it, I will attempt to use the FF web debug tools to see where it's locking up.

Modified by megawhite

Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
7869 solutions 64153 answers

Helpful Reply

The first time I access the Options page during a session, it is rendered (black text) but it is locked up for 10-20 seconds. I think it is building the "Applications" list which may involve querying the Windows Registry for information about my default applications. Later visits to the page operate normally.

(I'm guessing about the Applications list, but back when Applications was its own panel on the Options page instead of being part of the main panel, that was the panel with a long loading delay.)

The first time I access the Options page during a session, it is rendered (black text) but it is locked up for 10-20 seconds. I think it is building the "Applications" list which may involve querying the Windows Registry for information about my default applications. Later visits to the page operate normally. (I'm guessing about the Applications list, but back when Applications was its own panel on the Options page instead of being part of the main panel, that was the panel with a long loading delay.)
Was this helpful to you? 1
Quote
ganpati23 0 solutions 1 answers

I'm using a Mac and I have no CPU problems. But I had this issue on my iMac but not on the MBP or MBA.

All accounts are synced and running exactly the same extensions etc, so it shouldn't be working for two but not the other one.

I had been going to preferences from File in the top left menu, but I followed the advice and went to the menu icon (3 horizontal bars on the right) and there it displayed the preferences page perfectly.

So I went back to the File menu on the top left and clicked preferences from that.

Initially, the page displayed as badly as before, as in the OP's screengrab.

But after one second, it fixed itself.

So I'd advise trying to open it from the icon, and if that works, then opening it from the File menu.

Good luck everyone.

I'm using a Mac and I have no CPU problems. But I had this issue on my iMac but not on the MBP or MBA. All accounts are synced and running exactly the same extensions etc, so it shouldn't be working for two but not the other one. I had been going to preferences from File in the top left menu, but I followed the advice and went to the menu icon (3 horizontal bars on the right) and there it displayed the preferences page perfectly. So I went back to the File menu on the top left and clicked preferences from that. Initially, the page displayed as badly as before, as in the OP's screengrab. But after one second, it fixed itself. So I'd advise trying to open it from the icon, and if that works, then opening it from the File menu. Good luck everyone.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.