X
Tap here to go to the mobile version of the site.

Support Forum

A website keeps opening when I open Firefox and it is clearly a phishing site. How do I block it?

Posted

Since yesterday I've had the following page: https://go.net-dz3.stream/flix/index-en-nflix.html?country=CA&td=www.sundownerstravel.com&br=Firefox&isp=Firefox&cep=9n4HnbeZLCdnJzW-ZP5n9O9Iqzt-NCmWCKd5aFIYCQY4sUzYyC7t3YxZP_wiyTniVyKD7G0XeRpJ6Ns-mGsDl8d46hRTsOMT-BdW3cT9Ybj4BBU5mFIN2X6vE3wW3F9d8WZtdGU5sRuLnNKV9E5eOsUbdZJwPPHTgdRml-xfh21zpHWrSADLTSy5mefYFRa_bBfcrXNnuW4k_hqPsaGazSil8cLpPE_nODhBm5OGdoUosRsQGN1nhgszacVIP4qP&2=1975&1=6602932457161360092&3=1975-da8f03az#

open itself as the first page when I open Firefox. (And no it hasn't made itself my automatic home page)

After I closed my browser yesterday, every time I reopened it, it did not open this page, but again this morning upon my first time opening the browser, it opened this page.

Trouble is, I cannot seem to find a way in Firefox to block this page from opening anymore. Is there really no way in Firefox to block a specific page from opening?

Additionally, how is it opening this? I use Norton safe web and it doesn't recognize this page as a phishing site. Not sure where I picked it up but I do a lot of online research for work.

Thanks Tracy

Since yesterday I've had the following page: https://go.net-dz3.stream/flix/index-en-nflix.html?country=CA&td=www.sundownerstravel.com&br=Firefox&isp=Firefox&cep=9n4HnbeZLCdnJzW-ZP5n9O9Iqzt-NCmWCKd5aFIYCQY4sUzYyC7t3YxZP_wiyTniVyKD7G0XeRpJ6Ns-mGsDl8d46hRTsOMT-BdW3cT9Ybj4BBU5mFIN2X6vE3wW3F9d8WZtdGU5sRuLnNKV9E5eOsUbdZJwPPHTgdRml-xfh21zpHWrSADLTSy5mefYFRa_bBfcrXNnuW4k_hqPsaGazSil8cLpPE_nODhBm5OGdoUosRsQGN1nhgszacVIP4qP&2=1975&1=6602932457161360092&3=1975-da8f03az# open itself as the first page when I open Firefox. (And no it hasn't made itself my automatic home page) After I closed my browser yesterday, every time I reopened it, it did not open this page, but again this morning upon my first time opening the browser, it opened this page. Trouble is, I cannot seem to find a way in Firefox to block this page from opening anymore. Is there really no way in Firefox to block a specific page from opening? Additionally, how is it opening this? I use Norton safe web and it doesn't recognize this page as a phishing site. Not sure where I picked it up but I do a lot of online research for work. Thanks Tracy

Additional System Details

Installed Plug-ins

  • Shockwave Flash 24.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

More Information

Tyler Downer
  • Top 25 Contributor
  • Moderator
1530 solutions 10669 answers

I would strongly suggest the following:

  • Download Malwarebytes (www.malwarebytes.org), run a full scan
  • Then, update to Firefox 62.
  • Finally, I'd remove all Norton products, and use the built in Windows Defender
  • If you can, update to Windows 10
I would strongly suggest the following: * Download Malwarebytes (www.malwarebytes.org), run a full scan * Then, update to Firefox 62. * Finally, I'd remove all Norton products, and use the built in Windows Defender * If you can, update to Windows 10

Question owner

Thanks for the info.. I will try the malwarebytes but I'm not removing my Norton products. Sorry but no.

No updates to Windows 10 either as too many programs won't work properly anymore.

Thanks for the info.. I will try the malwarebytes but I'm not removing my Norton products. Sorry but no. No updates to Windows 10 either as too many programs won't work properly anymore.
jscher2000
  • Top 10 Contributor
8689 solutions 71030 answers

Usually Firefox will start up with the built-in home page or, if you have changed the startup/home page setting, with your previous session tabs or with the page of your choice.

If another page is shown, here are some other things to check:

(1) Extensions (should not be an issue after a Refresh)

One possible culprit would be an extension. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

(2) Hijacked Shortcut

The Firefox icon can be set up to launch one or more specific pages at startup (or more specifically, when you use the icon). To check whether that is set:

First, open the shortcut as follows (this is how it works on Windows 7, hopefully it's similar on Windows 8.1):

  • Desktop shortcut: right-click the icon, choose Properties
  • Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties

Windows normally will select the Shortcut tab. If not, go ahead and click the Shortcut tab.

You'll see the Target highlighted. On Windows, that usually is no more and no less than the following (depending on 32-bit/64-bit):

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
"C:\Program Files\Mozilla Firefox\firefox.exe"

If anything follows after that (for example, "http://example.com"), try clearing it out.

After OK'ing the Properties dialog, you can test right away to confirm that Firefox now launches only your desired home page. Either:

  • double-click desktop shortcut
  • right-click pinned taskbar icon, click Mozilla Firefox

Success?

Usually Firefox will start up with the built-in home page or, if you have changed the startup/home page setting, with your previous session tabs or with the page of your choice. If another page is shown, here are some other things to check: '''(1) Extensions''' (should not be an issue after a Refresh) One possible culprit would be an extension. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). Any improvement? '''(2) Hijacked Shortcut''' The Firefox icon can be set up to launch one or more specific pages at startup (or more specifically, when you use the icon). To check whether that is set: First, open the shortcut as follows (this is how it works on Windows 7, hopefully it's similar on Windows 8.1): * Desktop shortcut: right-click the icon, choose Properties * Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties Windows normally will select the Shortcut tab. If not, go ahead and click the Shortcut tab. You'll see the Target highlighted. On Windows, that usually is no more and no less than the following (depending on 32-bit/64-bit): "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" "C:\Program Files\Mozilla Firefox\firefox.exe" If anything follows after that (for example, "http://example.com"), try clearing it out. After OK'ing the Properties dialog, you can test right away to confirm that Firefox now launches only your desired home page. Either: * double-click desktop shortcut * right-click pinned taskbar icon, click Mozilla Firefox Success?