X
Tap here to go to the mobile version of the site.

Support Forum

when i open firefox this comes up on a blank page,window id="main- window"

Posted

ive reinstalled firefox but its still the same

ive reinstalled firefox but its still the same

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; BRI/2; MASM; .NET4.0C; .NET4.0E; InfoPath.2; rv:11.0) like Gecko

More Information

McCoy
  • Top 10 Contributor
545 solutions 5139 answers
Hello Antoniou, Please see this thread : https://support.mozilla.org/en-US/questions/1234450 and this bug report : https://bugzilla.mozilla.org/show_bug.cgi?id=1492459
philipp
  • Top 25 Contributor
  • Moderator
5315 solutions 23463 answers

Helpful Reply

hi, it appears that your avast/avg security software has wrongfully deleted important parts of the browser that are necessary for proper operations.

in order to recover, please try to start firefox into safemode by pressing the shift key while it's launching. if you get it to open up normally this way then please enter about:config into the address bar (confirm the warning hint in case it shows up), and search for the preference named intl.locale.requested - right-click and reset that preference and then try to start firefox normally again.

Troubleshoot Firefox issues using Safe Mode

hi, it appears that your avast/avg security software has wrongfully deleted important parts of the browser that are necessary for proper operations. in order to recover, please try to start firefox into safemode by pressing the shift key while it's launching. if you get it to open up normally this way then please enter '''about:config''' into the address bar (confirm the warning hint in case it shows up), and search for the preference named '''intl.locale.requested''' - right-click and reset that preference and then try to start firefox normally again. [[Troubleshoot Firefox issues using Safe Mode]]

Question owner

Thanks guys

Thanks guys
raul202 0 solutions 2 answers

I have tried to do as philipp says but cannot find the preference named intl.locale.requested. The list skips from intl.keyboard.per_window_layout to intl.menuitems.alwaysappendaccesskeys.

I have tried to do as philipp says but cannot find the preference named intl.locale.requested. The list skips from intl.keyboard.per_window_layout to intl.menuitems.alwaysappendaccesskeys.
philipp
  • Top 25 Contributor
  • Moderator
5315 solutions 23463 answers

hi raul202, in this case another thing should help you get back to a working browser: while in safemode, enter about:support into the address bar and hit the button to open the profile folder. then close all running firefox processes and delete the file named addonStartup.json.lz4 inside your profile folder, now firefox should be able to start up normally again.

hi raul202, in this case another thing should help you get back to a working browser: while in safemode, enter about:support into the address bar and hit the button to open the profile folder. then close all running firefox processes and delete the file named addonStartup.json.lz4 inside your profile folder, now firefox should be able to start up normally again.
raul202 0 solutions 2 answers

Thank you Philipp, you are a star! All is working perfectly now :)

Thank you Philipp, you are a star! All is working perfectly now :)