Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Youtube.com on my browser is not loading correctly

  • 24 replies
  • 1 has this problem
  • 311 views
  • Last reply by haydon97

more options

I use youtube alot and just recently the site stopped loading correctly just displaying parts of the header bar at the top of the page and nothing else at all bellow I have tried other browsers having the same issue and also on opera on a hisesnse smart tv that also doesnt work. We have 3 seperate networks at home and this issue is only ocuring on the one that im using no dns settings have been changed to cause this issue no network speed issues are present and i have also tried clearing cookies and cache and still no result please help im running out of ideas

https://screenshots.firefox.com/TkK4VKqpDBLRPyCY/www.youtube.com

All Replies (20)

more options

What is the actual link? The screen shot doesn't have anything to be of help.

more options

The link is https://www.youtube.com/?gl=GB this is without being logged in all other google services work fine

more options

Please disable NoScript 10.1.9.6 when you want to see something. Or learn how to whitelist sites. Your adblocker may also be blocking something that Youtube wants.

Please let us know if this solved your issue or if need further assistance.

more options

I've tried it with all addons disabled but still getting the same issue, im only getting the issue with youtube it worked before yesterday with the same version of firfox and all the addons I was using how do I whitelist a site

Modified by haydon97

more options

haydon97 said

I use youtube alot and just recently the site stopped loading correctly just displaying parts of the header bar at the top of the page and nothing else at all bellow

I have tried other browsers having the same issue and also on opera on a hisesnse smart tv that also doesnt work.

We have 3 seperate networks at home and this issue is only ocuring on the one that im using no dns settings have been changed to cause this issue no network speed issues are present and i have also tried clearing cookies and cache and still no result please help im running out of ideas

Are you able to access YouTube in Google Chrome, or do you not have that browser installed?

Do embedded videos play? For example, I have a short and boring one here: https://www.jeffersonscher.com/gm/google-hit-hider/

You mentioned having multiple networks. Do they all run through the same router, but have different SSIDs, for example? And if you switch networks on an affected device, then everything works OK?

When multiple browsers on the same computer are affected, or multiple devices on the same network, it does make sense to check DNS as you did. Some routers have interceptors, such as security software or parental control software, or bandwidth restrictors, which could be specific to a particular network. I don't know whether that could be a factor on yours.

I assume you've power-cycled the router(s) just in case.

more options

all our networks run through the same router as vpns, I assume the ssids are different im not sure its my dad who manages all that stuff

youtube works fine on all other networks and all networks are managed in Opendns. and i also tried all other browsers including IE, Edge, Chrome on my desktop, and Opera on a smart tv

The link you gave me comes with a Your conection is not secure error with www.youtube-nocookie.com ive included the screenshot. firefox will not allow me to continue to the site.

we havn't tried powercycleing the routers yet

Modified by haydon97

more options

haydon97 said

The link you gave me comes with a Your conection is not secure error with www.youtube-nocookie.com ive included the screenshot. firefox will not allow me to continue to the site.

Could you click the blue SEC_ERROR_UNKNOWN_ISSUER code and see whether Firefox shows an encoded version of the problem certificate? You can copy/paste that into a reply, and I (or another volunteer) can decode it to see whether it points to a "man in the middle" that might be causing this issue. If you want to decode it yourself there are many sites for that; I use https://certlogik.com/decoder/ and look at the "Issuer" or "Issued by" section for clues.

more options

https://www.youtube-nocookie.com/embed/u0431tculpg?rel=0

Peer's Certificate issuer is not recognised.

HTTP Strict Transport Security: false HTTP Public Key Pinning: true

Certificate chain:


BEGIN CERTIFICATE-----

MIIDWjCCAkKgAwIBAgIEW6EyBDANBgkqhkiG9w0BAQsFADBAMS4wLAYDVQQDDCVD aXNjbyBVbWJyZWxsYSBTZWNvbmRhcnkgU3ViQ0EgbG9uLVNHMQ4wDAYDVQQKDAVD aXNjbzAeFw0xODA5MTYxNjU1MzNaFw0xODA5MjExNjU1MzNaMHUxCzAJBgNVBAYT AlVTMRMwEQYDVQQIDApDYWxpZm9ybmlhMRYwFAYDVQQHDA1TYW4gRnJhbmNpc2Nv MRYwFAYDVQQKDA1PcGVuRE5TLCBJbmMuMSEwHwYDVQQDDBh3d3cueW91dHViZS1u b2Nvb2tpZS5jb20wggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEKAoIBAQDm5L73 LC1KOUAN/NpatvpSEvLMFJG5ZopYO78DetZHiI/2UypuJuQU9VGcuHiLzEHSDb// GkyZEE/qF+GmYJYrwnV2j7R9/D0EQuELnT9MI9n9NZiePC9x4Mfsq2jRW5Klu1EJ UIzRLxmzm23moOcYas+3jThylGRJ9lAyRr6rXYfkMOiUzQt6tRE3Bs0E79caxPtn RdpSWjXaCKW1lmsRPFd4hKMFOE+dI2AF8eFrxb80+8j+tdjqEm+QKDEbhc2Z+AxU EwxLePF5ZeSeEj7s73K5QaqKq0Za9dXAHiT3ijOO+8F8jUxJJn4maMOSxt5Sc76b Bu21HeKloqsAjmApAgMBAAGjJzAlMCMGA1UdEQQcMBqCGHd3dy55b3V0dWJlLW5v Y29va2llLmNvbTANBgkqhkiG9w0BAQsFAAOCAQEATK42XwDDCKCvivzMXSZYBrnv bH9bwgu3rvh3DF11c+1EZkL/Kgi4Z2A0O8dnYMXss5+jiBNHVJYSBrQQB3r5mj1j i041788fSHho1NLFul4h2fuY24Q94LhrKr7VDmTQyaK0HmslXR0CYvpWKZ5YXgP4 izp3BNJkjxKyFAJiX0lKEkGDHgs7uhejRb9hT8DsA+xC2tHTLqVhGtU2a0WsFvNZ 4kAuh/gzB/TpndXYeRE55VMPIBh5KBLvCxSLdQn/toeC24s0uFB7iOMA2tm2B9te Yzr3NFvQuDnaEXTOXpthQhxL/KGmr7IY3fGmf7miG2fMJQPa6JU9kkEbysv3lA==


END CERTIFICATE-----
BEGIN CERTIFICATE-----

MIID3DCCAsSgAwIBAgIQXUlvOdn6Ss+/v0Jo4ektiTANBgkqhkiG9w0BAQsFADA3 MSUwIwYDVQQDDBxDaXNjbyBVbWJyZWxsYSBQcmltYXJ5IFN1YkNBMQ4wDAYDVQQK DAVDaXNjbzAeFw0xODA5MTYxOTM1MzhaFw0xODA5MjcxOTM1MzhaMEAxLjAsBgNV BAMMJUNpc2NvIFVtYnJlbGxhIFNlY29uZGFyeSBTdWJDQSBsb24tU0cxDjAMBgNV BAoMBUNpc2NvMIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEA5uS+9ywt SjlADfzaWrb6UhLyzBSRuWaKWDu/A3rWR4iP9lMqbibkFPVRnLh4i8xB0g2//xpM mRBP6hfhpmCWK8J1do+0ffw9BELhC50/TCPZ/TWYnjwvceDH7Kto0VuSpbtRCVCM 0S8Zs5tt5qDnGGrPt404cpRkSfZQMka+q12H5DDolM0LerURNwbNBO/XGsT7Z0Xa Ulo12giltZZrETxXeISjBThPnSNgBfHha8W/NPvI/rXY6hJvkCgxG4XNmfgMVBMM S3jxeWXknhI+7O9yuUGqiqtGWvXVwB4k94ozjvvBfI1MSSZ+JmjDksbeUnO+mwbt tR3ipaKrAI5gKQIDAQABo4HaMIHXMB8GA1UdIwQYMBaAFDdBmFo9IC5nyg0yyyfJ 4MXtup/pMBIGA1UdEwEB/wQIMAYBAf8CAQAwDgYDVR0PAQH/BAQDAgGGMB0GA1Ud DgQWBBRyhqIeYKr534OnZ7RbRQtpc+73CjBxBggrBgEFBQcBAQRlMGMwIwYIKwYB BQUHMAGGF2h0dHA6Ly9vY3NwLm9wZW5kbnMuY29tMDwGCCsGAQUFBzAChjBodHRw Oi8vY2FjZXJ0cy5vcGVuZG5zLmNvbS80NDg2M0FCMTU0NjQ1OEQ3Mi5jcnQwDQYJ KoZIhvcNAQELBQADggEBAEmOkVyLChnyUbfuDGLMsUxNQViFWHI1+v+tbnuI8hhg DOkiHgqVdYOtK2fM9BouODXCEwV2QoS7+T/0DttFnx0aVQKDEl0Y6+VBGKeVQIMy iGHldGPmKDLVhhU5KtA+nEpyE478bSN4lfLiCEY96CjJS7r2L06mwa3Q0ir2Q9nW AAN8BFukDsFldMiy4dEVDnoTcXJqbKXEo95iEAJmmw6W1lC2H/XjUjIjAWuakQSu cDk0CoccssXGBYTqITH9GRKEsBLDwDlSyFXhmlx5z/pXy9YcJXrL5fFVNCO3aItx LKm4SDUwKnLl9HhZIQr6BTvL3QQsJltNKWdVbYDuDPI=


END CERTIFICATE-----
BEGIN CERTIFICATE-----

MIIEgTCCA2mgAwIBAgIJBEhjqxVGRY1yMA0GCSqGSIb3DQEBCwUAMDExDjAMBgNV BAoTBUNpc2NvMR8wHQYDVQQDExZDaXNjbyBVbWJyZWxsYSBSb290IENBMB4XDTE2 MDYyODE1NDAxMVoXDTIxMDYyODE1NDAxMVowNzElMCMGA1UEAwwcQ2lzY28gVW1i cmVsbGEgUHJpbWFyeSBTdWJDQTEOMAwGA1UECgwFQ2lzY28wggEiMA0GCSqGSIb3 DQEBAQUAA4IBDwAwggEKAoIBAQCvR/Tm+U0VahUptIKAkU7BwSKgO1HO0CMdZXCO OLFh9+pCoG1Ly7UiudFAumlfA4kzs1SS9xR2ax0TYIQG84hJsoOPSaZU6wkWWJDq mZVD4+LSPZLUuMWbgWy8/BuqKKL32JjInU/LRXF3AaapHT6eprR5vv5MYSWzFv4r QzhMXy8i8eK48EKsQyf3UBUHdUmOQFBYuRkYlKdave0ipxjMUYKh6DwJX+5psl7S lwHxzKxppwBqZhI5GiuWIs4RhuB+1hOr1zuAb9Oy8WNryXTijXQJ+thl74oo0CoV XS2nZQyDk1X2CUOpTy2Kj4W4ucd4Y1jRp37FkWQwivWq5DU5AgMBAAGjggGUMIIB kDAOBgNVHQ8BAf8EBAMCAYYwEgYDVR0TAQH/BAgwBgEB/wIBATBSBgNVHSAESzBJ MEcGCisGAQQBCRUBHQAwOTA3BggrBgEFBQcCARYraHR0cDovL3d3dy5jaXNjby5j b20vc2VjdXJpdHkvcGtpL3BvbGljaWVzLzAdBgNVHQ4EFgQUN0GYWj0gLmfKDTLL J8ngxe26n+kwTAYDVR0fBEUwQzBBoD+gPYY7aHR0cDovL3d3dy5jaXNjby5jb20v c2VjdXJpdHkvcGtpL2NybC9jaXNjb3VtYnJlbGxhcm9vdC5jcmwwgYcGCCsGAQUF BwEBBHsweTBJBggrBgEFBQcwAoY9aHR0cDovL3d3dy5jaXNjby5jb20vc2VjdXJp dHkvcGtpL2NlcnRzL2Npc2NvdW1icmVsbGFyb290LmNlcjAsBggrBgEFBQcwAYYg aHR0cDovL3BraWN2cy5jaXNjby5jb20vcGtpL29jc3AwHwYDVR0jBBgwFoAUQ3MA 3iS6QBpAVCx9fNUASIkMcKQwDQYJKoZIhvcNAQELBQADggEBAAhlqdX9AAHOyNPv KA44ulyoprNnXp62XeYnlKRgCPvShWW2eDIMOePS8+RvuPGJdtAm1YoPa9hn0WO2 L+jHmnob7so2yc3c02uio9Q4VqPCuA1T/RmmXerpvHtxx1FfUhboBoiGvP/dnFTX DF0lzLEllP3tYZOH0wjsTjhPERN60zR29lKHludW9ZRc5Fkxj5ZwALvAZ2Iqb0HG DwIhJJjXUpJjZXQPRGQ8N+VDx2UqTf74g/rpKcALUERGFrrJMO0Z7yaiqVsVQ9/J 4FAJCjB6fkivL5SvmDWCB1ZeiRc2ud5qm/II0OuGdtX+mo0/Lo9Lh9Tdg2LxUxEn 7cAtMK0=


END CERTIFICATE-----
more options

Hmm, the URL is intercepted by OpenDNS (certificate issuer is Cisco Umbrella Secondary SubCA lon-SG). I wonder why?

Firefox might not allow it, but if you try an unsecure (http://) version of that URL, do you get an OpenDNS explainer of any kind:

http://www.youtube-nocookie.com/embed/u0431tculpg?rel=0

more options

this is what I get my network is quite restricted so anything catogorised as Video sharing that is not https://www.youtube.com/?gl=GB will get blocked even social networking

more options
more options

the first one just displays completly blank nothing at all the second one displays a music note icon in the middle of the page this is what im getting on the last link

Modified by haydon97

more options

Hmm, if the first two are allowed, I think you should see more of the page. But anyway, I don't have a way to simulate what you're experiencing. Can you escalate it to whoever is in charge of the OpenDNS settings?

more options

i have tried my dad cant work out what is causing it i can log in on another network no problem but im suposed to be permantly on another network

i did have a look at view page info on the site and i dont know if this helps its on the security section in that window

more options

Maybe this Community post will help with making YouTube work again (for Dad, not you):

https://support.opendns.com/hc/en-us/community/posts/360014827206/comments/360000659306

more options

youtube is now displaying correctly on all browsers but this time if i click on a video to watch it just displays a black window with the circle buffering logo, this is after a windows 10 cumulative update there was two of them for version 1303 today.

Modified by haydon97

more options

Could you try this:

Open the Network Monitor it the lower part of the tab using either:

  • "3-bar" menu button > Web Developer > Network
  • (menu bar) Tools > Web Developer > Network
  • (Windows) Ctrl+Shift+e

When you reload the page in the top part of the tab, Firefox should start listing all the files it is requesting, along with information about whether the request was successful.

Do you see any requests that are not successful (200) or redirected and then successful (301 or 302) or satisfied from cache (sometimes 304)? That could indicate something else that is blocked.

more options

It seems im getting a lot of

https://r2---sn-cu-abfe.googlevideo.com/generate_204?conn2

SEC_ERROR_UNKNOWN_ISSUER

on video playback

how do I save all the results

Modified by haydon97

more options

I can also download videos using this site https://www.converto.io/en

but i dont want to keep downloading videos each time i want to watch a video

more options

I suspect it's the same issue, that the site is replaced by an OpenDNS page.

  1. 1
  2. 2