X
Tap here to go to the mobile version of the site.

Support Forum

Firefox crashes over night, every night, with signature "OOM | small"

Posted

Sometimes it happens during the day too, but it always happens every night.

When I check the crash reports, the signature line says "OOM | small", which confirms my observation that it's running out of memory. On those occasions where it happens during the day, and I can catch it, the Peak Working Set in Windows Task Manager reveals that Firefox used all available memory before it crashed. (I have 8 gb total.)

It doesn't make any difference how many tabs I have open. I can have one tab open - about:home e.g. - and it can still crash with "OOM | small".

I wonder if Firefox spawns some background process that typically only runs at night, and that process is failing for some reason.

Sometimes it happens during the day too, but it always happens every night. When I check the crash reports, the signature line says "OOM | small", which confirms my observation that it's running out of memory. On those occasions where it happens during the day, and I can catch it, the Peak Working Set in Windows Task Manager reveals that Firefox used all available memory before it crashed. (I have 8 gb total.) It doesn't make any difference how many tabs I have open. I can have one tab open - about:home e.g. - and it can still crash with "OOM | small". I wonder if Firefox spawns some background process that typically only runs at night, and that process is failing for some reason.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 30.0 r0
  • 5.1.50907.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

Tyler Downer
  • Top 25 Contributor
  • Moderator
1529 solutions 10658 answers

Please update to Firefox 62, and let us know if you still see the issue.

Please update to Firefox 62, and let us know if you still see the issue.

Question owner

This isn't a new issue on my machine, as it's spanned several versions of Firefox, so upgrades haven't made a difference.

If there's a known bug related to this issue that's either being actively tracked or has since been fixed, that would be relevant and helpful to know.

Thank you.

This isn't a new issue on my machine, as it's spanned several versions of Firefox, so upgrades haven't made a difference. If there's a known bug related to this issue that's either being actively tracked or has since been fixed, that would be relevant and helpful to know. Thank you.
Shadow110 1072 solutions 14836 answers

Out of Memory is out of Memory. Each machine uses less or more than another. Firefox Quantum can use more on 1 Identical setup than another. When a system has no motherboard updates or bios updates and still running the cd drivers that came in the box you will have issues.

If your looking to save ram which it seems you should be please have a look through these : To be Checked and turned off unless needed for accessibility : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Multi-Processor Support : Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Only Disable as last resort.

Multi-processor Can completely disable it this way in about:config : dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Only move to esr if low ram and old system.

Firefox Extended Release Version : Firefox ESR does not come with the latest features but it has the latest security and stability fixes.

If do please :

Optimize Windows 7

Please let us know if this solved your issue or if need further assistance.

Out of Memory is out of Memory. Each machine uses less or more than another. Firefox Quantum can use more on 1 Identical setup than another. When a system has no motherboard updates or bios updates and still running the cd drivers that came in the box you will have issues. If your looking to save ram which it seems you should be please have a look through these : '''''To be Checked and turned off unless needed for accessibility : ''''' Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser. '''''Multi-Processor Support : ''''' Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on. Only Disable as last resort. '''''Multi-processor Can completely disable it this way in about:config :''''' dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false *http://kb.mozillazine.org/About:config Only move to esr if low ram and old system. '''''Firefox Extended Release Version :''''' Firefox ESR does not come with the latest features but it has the latest security and stability fixes. *https://support.mozilla.org/en-US/kb/switch-to-firefox-extended-support-release-esr If do please : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Optimize Windows 7 *https://support.microsoft.com/en-ca/help/15055/windows-7-optimize-windows-better-performance *https://www.sevenforums.com/tutorials/11728-optimize-windows-7-a.html *https://www.thewindowsclub.com/beginners-tips-to-optimize-windows-7-for-better-performance Please let us know if this solved your issue or if need further assistance.
Tyler Downer
  • Top 25 Contributor
  • Moderator
1529 solutions 10658 answers

Please update to Firefox 62, then give the crash ID's. We can't help without the most recent version of Firefox being tested

Please update to Firefox 62, then give the crash ID's. We can't help without the most recent version of Firefox being tested
cor-el
  • Top 10 Contributor
  • Moderator
17422 solutions 157414 answers

It is possible that you have security or cleanup software that runs during the night that is causing this issue.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

It is possible that you have security or cleanup software that runs during the night that is causing this issue. Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10