X
Tap here to go to the mobile version of the site.

Support Forum

My Facebook page keeps prompting "For a better experience on Facebook, update your browser." I have a Mac OS 10.13.6 + have loaded Firefox 42.0. Suggestions?

Posted

Do I have the most up-to-date compatible version of Firefox for my MacBookPro, OS 10.13.6? I have Firefox 42.0. Thank you.

Do I have the most up-to-date compatible version of Firefox for my MacBookPro, OS 10.13.6? I have Firefox 42.0. Thank you.

Chosen solution

Hello elliscashmore,

The Firefox version you are running now is very old and doesn't get any security updates - puts you at risk.

Unless you need the ESR version, you should download Firefox release version 62.0, which you can download from here :

https://www.mozilla.org/firefox/all/

If you need the ESR version version (because you use plugins that are not supported by the release version), you can download the latest version from here :

https://www.mozilla.org/firefox/organizations/all/

Also see : https://www.mozilla.org/en-US/firefox/62.0/system-requirements/h

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.23
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Microsoft Lync 2010 Meeting Join Plug-in
  • Office Live Update v1.0
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 31.0 r0
  • 5.1.10411.0

Application

  • Firefox 42.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:42.0) Gecko/20100101 Firefox/42.0
  • Support URL: https://support.mozilla.org/1/firefox/42.0/Darwin/en-US/

Extensions

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x0166
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: False
  • webglRenderer: Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
McCoy
  • Top 10 Contributor
546 solutions 5143 answers

Chosen Solution

Hello elliscashmore,

The Firefox version you are running now is very old and doesn't get any security updates - puts you at risk.

Unless you need the ESR version, you should download Firefox release version 62.0, which you can download from here :

https://www.mozilla.org/firefox/all/

If you need the ESR version version (because you use plugins that are not supported by the release version), you can download the latest version from here :

https://www.mozilla.org/firefox/organizations/all/

Also see : https://www.mozilla.org/en-US/firefox/62.0/system-requirements/h

Hello elliscashmore, The Firefox version you are running now is very old and doesn't get any security updates - puts you at risk. Unless you need the ESR version, you should download Firefox release version 62.0, which you can download from here : https://www.mozilla.org/firefox/all/ If you need the ESR version version (because you use plugins that are not supported by the release version), you can download the latest version from here : https://www.mozilla.org/firefox/organizations/all/ Also see : https://www.mozilla.org/en-US/firefox/62.0/system-requirements/h