Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't get rid of "bookmark" with autofill in address bar.

  • 3 replies
  • 1 has this problem
  • 54 views
  • Last reply by FredMcD

more options

For some reason "https://docs.google.com/" shows up when I put in "d" in my address bar even though I don't have it in my bookmarks. Selecting it with the arrows keys or the mouse and pressing the delete key removes it but when I try again in a new tab with "d" it shows up again. I don't know why it shows up as my first choice nor do I know why it's even there but I want it to never show up when I search. How can I permanently remove it?

Chosen solution

See if this helps;

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.


If there is still a problem,

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

See if this helps;

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.


If there is still a problem,

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

Starting it in safe mode seemed to solve that problem after I deleted it when it showed up. It's working fine in regular mode. Thanks man.

more options

Glad to help. Safe Surfing.