X
Tap here to go to the mobile version of the site.

Support Forum

Firefox using more CPU than Chrome even though Chrome has 46 tabs open and Firefox only has 18

Posted

I am using Firefox, am wanting to transfer from Chrome but then I opened 18 tabs and looked at task manager and its ridiculous! All help is much appreciated as to why Chrome is actually being nice to my computer whereas Firefox is not!

Thanks in advance!

I am using Firefox, am wanting to transfer from Chrome but then I opened 18 tabs and looked at task manager and its ridiculous! All help is much appreciated as to why Chrome is actually being nice to my computer whereas Firefox is not! Thanks in advance!
Attached screenshots

Additional System Details

Installed Plug-ins

360 Total Security Empty Cache uBlock Origin

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

More Information

Shadow110 1072 solutions 14836 answers

Hi, what one uses is not the same as another. Use 3 Systems and all use different amount even though all are setup the same with same programs. Just over 1.5 is good. No idea of your total ram as you did not say. If have ram left then use it. https://www.howtogeek.com/334594/stop-complaining-that-your-browser-uses-lots-of-ram-its-a-good-thing/

To be Checked and turned off unless needed for accessibility : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Multi-Processor Support : Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Only Disable as last resort.

Multi-processor Can completely disable it this way in about:config : dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Only move to esr if low ram and old system.

Firefox Extended Release Version : Firefox ESR does not come with the latest features but it has the latest security and stability fixes.

If do please :

Hi, what one uses is not the same as another. Use 3 Systems and all use different amount even though all are setup the same with same programs. Just over 1.5 is good. No idea of your total ram as you did not say. If have ram left then use it. https://www.howtogeek.com/334594/stop-complaining-that-your-browser-uses-lots-of-ram-its-a-good-thing/ '''''To be Checked and turned off unless needed for accessibility : ''''' Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser. '''''Multi-Processor Support : ''''' Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on. Only Disable as last resort. '''''Multi-processor Can completely disable it this way in about:config :''''' dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false *http://kb.mozillazine.org/About:config Only move to esr if low ram and old system. '''''Firefox Extended Release Version :''''' Firefox ESR does not come with the latest features but it has the latest security and stability fixes. *https://support.mozilla.org/en-US/kb/switch-to-firefox-extended-support-release-esr If do please : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer