Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Spellchecking stopped working. What could be wrong?

  • 17 replies
  • 2 have this problem
  • 316 views
  • Last reply by cor-el

more options

Spellchecking stopped working as it did before. Only have EN in the list despite Swedish installed. Bug?

FF 62.0 Ubuntu 18.04

Chosen solution

Ok. Reinstalled FF and everything. Working now. Still need to re-select spellchecking for new pages.

It did work before so something probably happened with the updated Language Pack 27/8 or 30/8.

Once again, thanks for the help.

Read this answer in context 👍 1

All Replies (17)

more options

Only a few locales of the Official builds of Firefox from mozilla.org or www.mozilla.org/firefox/all/ comes with a dictionary installed.

Make sure you have appropriate Dictionary installed and selected in Language. https://addons.mozilla.org/firefox/language-tools/

https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker#w_adding-dictionaries

The third-party Linux distro provided builds of Firefox may have Language packs installed with it but not Dictionaries.Language Packs are used to change the language of the Firefox user interface.

Modified by James

more options

Read my question

more options

Thank you but please read my question.

more options

Of course I read your question, Please be nice.

You only said you have Swedish installed, however you did not state you were referring to Dictionary (which you need) or Language Pack.

Also you are using a third-party builds from Ubuntu which could be a issue as there has been some minor issues at times in the past few major Release and they provided a package update soon after.

Modified by James

more options

I say the same. I just explained something and you obviously didn't read it properly. But that's ok. I had a working spell checker. I reinstalled my language. I have all I need installed but I can only see and select English in the dropdown. Looks like bug. As you said, could be something with Ubuntu as it suddenly appeared.

more options

You can check the layout.spellcheckDefault pref on the about:config page.

You can reset the layout.spellcheckDefault pref via the right-click context menu.

more options

palbergstrom said

I say the same. I just explained something and you obviously didn't read it properly. But that's ok. I had a working spell checker. I reinstalled my language.

So you think "Only have EN in the list despite Swedish installed." sufficiently explained things in your OP.

As I pointed out it did not since there is a Swedish Dictionary and language pack on https://addons.mozilla.org/firefox/language-tools/

I get that you are not seeing a Swedish in the languages part of right-click and only a English option. You need to install Swedish dictionary to add language there. You have not specifically stated that you installed a dictionary, only stated you installed a language which could be in reference to Swedish language pack.

Would you believe that it is quite common for people to mistakenly think they needed a Language pack for the spellchecker and then wonder why they did not see it as a added language option in right-click languages.

Maybe the article will make the point more clear. https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker#w_adding-dictionaries

This explains how Language packs are used in case you are curious or were trying to make use of those instead of the Dictionaries. https://support.mozilla.org/en-US/kb/use-firefox-interface-other-languages-language-pack


However if you did do it right in installing the dictionary in language you wanted and it is not there even after a restart of Firefox then it could be a issue with the Firefox build from ubuntu.

Modified by James

more options

FFus3r said

You can check the layout.spellcheckDefault pref on the about:config page. You can reset the layout.spellcheckDefault pref via the right-click context menu.

In config I have status:standard, type:integer and value:1

What do you mean by reset? In config or in normal layout? In config I only have the normal Modify, Copy...

more options

normal layout

more options

James said

I get that you are not seeing a Swedish in the languages part of right-click and only a English option.

Yes and I explained that I did work before (self-explanatory) so nothing in your answer is a solution to me except that it might be in Ubuntu. Of course I already did what you suggested, reinstalling SE and all that, before I asked here. But I appreciate your help.

Modified by Pål Bergström

more options

FFus3r said

normal layout

Can not see a reset in context menu.

more options

I think this might be in the pack. See others have had the same issue. Found this at (though 6 month ago) https://addons.mozilla.org/sv-SE/firefox/addon/svenska-se-language-pack/reviews/:

"I have same problem. After installation I cannot see languagepack in menu. IMPORTEN: Many have same problem. Why do you wnat us to write opinion, if you do not write answer for solutions?"

Tried to install previous version but that didn't work. FF would't let me install from file.

Modified by Pål Bergström

more options

palbergstrom said

FFus3r said
normal layout

Can not see a reset in context menu.

how? its the last one in context menu.

more options

FFus3r said

palbergstrom said
FFus3r said
normal layout

Can not see a reset in context menu.

how? its the last one in context menu.

Don't have that. Only Add....

more options

Also tried Italian Lang Pack. Same thing. Only see EN.

I need to enable Spellchecking for each new page. FF doesn't remember the selection.

Same problems in FF Dev 63.0b4.

I call this a bug so I guess the only thing to do is to wait for a fix.

Thanks for your help.

more options

Chosen Solution

Ok. Reinstalled FF and everything. Working now. Still need to re-select spellchecking for new pages.

It did work before so something probably happened with the updated Language Pack 27/8 or 30/8.

Once again, thanks for the help.

more options

A language pack doesn't have anything to do with the spell checker. A language pack only provides translations of strings (text labels) for the user interface. You always have to install the dictionary separately if the dictionary isn't part of the Firefox locale you have installed. Only a few locales come with their own dictionary like en-US and for others you need to install the dictionary yourself via the Addons website. Both language packs and dictionaries are listed on this page, see the notice at the top.

Installing a dictionary add-on will add a new language option to your spell-checker, which checks your spelling as you type in Firefox.

Language packs change your browser's interface language, including menu options and settings.

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

  • Options/Preferences -> General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

Note that you need a dictionary and not a language pack that provides string translations for the user interface.

You can check the layout.spellcheckDefault pref on the about:config page.