Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The new update has cause my Facebook and online games to be slow and glitchy. I have followed the troubleshooting guide on your site, but it has not helped.

  • 11 replies
  • 2 have this problem
  • 24 views
  • Last reply by Shadow110

more options

The new update has cause my Facebook and online games to be slow and glitchy. I have followed the troubleshooting guide on your site, but it has not helped.

All Replies (11)

more options

Hi, please try : SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Performance > Uncheck to view)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

To be Checked and turned off unless needed for accessibility : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Multi-Processor Support : Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Only Disable as last resort.

Multi-processor Can completely disable it this way in about:config : dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

more options

Thank you. I did what you suggested, but it is still lagging. I think I will just restore to before the update.

more options

Hi it will just update again. You lose security going backwards.

please try a Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st:

then

more options

I tried that and I am still lagging badly. This update has really screwed me up. I am really upset about this. Internet Explorer is not an option with all its popups and Chrome is just awful. I don't know what I'm going to do.

more options

Ooh it gets better, after doing what you last suggested, I now no longer have any of my bookmarks. I have gathered these bookmarks for years. I am beginning to think that this was all a prank to make me look stupid.

more options

My download speed has dropped so much, things time out.

more options

Disable Hardware Acceleration


Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

more options

This helped. It is still a little slow, but manageable now. Thank you

more options

Hi, it looks like you did not follow my 2 posts. What your saying is helping was in my 1st post under : Multi-Processor Support

Your loosing your bookmarks is again not reading the post and backing up : https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer

Please give your self a scan : https://www.malwarebytes.com/

more options

I did read both posts and I followed it to the letter, but all it did was backup the link, not the bookmarks.It doesn't matter anymore. I have lost the work and I can't get it back.

more options

Let us know if find it there.