Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

got message that my pc cannot be upgraded to latest firefox because it runs XP, but my pc is running windows 7

  • 5 replies
  • 1 has this problem
  • 64 views
  • Last reply by msraber

more options

I transferred all my files from an XP machine 2 years ago, to a Windows 7 machine. Don't know why I am getting message that my Firefox can no longer be upgraded -- Firefox seems to think I am still using XP

Chosen solution

Check that you do not run Firefox in compatibility mode.

You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

Read this answer in context 👍 1

All Replies (5)

more options

It is possible your user agent is corrupted. https://support.mozilla.org/kb/how-reset-default-user-agent-firefox

Once you correct that, ensure that Firefox is not running in compatibility mode for Windows (https://support.microsoft.com/en-us/help/15078/windows-make-older-programs-compatible). You want to make sure Firefox isn't trying to run on Windows XP.

Then, go to www.getfirefox.com and download Firefox 62.

more options

Chosen Solution

Check that you do not run Firefox in compatibility mode.

You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

more options

THANKS FOR THE PROMPT HELP. BASIC PROBLEM WAS THAT FIREFOX WAS RUNNING IN A COMPATABILITY MODE.

more options

If you were to get updates it will be to 60.2.0 ESR and not the current Release 62.0

The current Release Firefox 62.0 is at www.mozilla.org/firefox/all/

You may have been running Firefox in Windows XP compatibility mode for a while as to why you have 52.9.0esr as Firefox 53.0 and later Requires Windows 7 or later.

Modified by James

more options

Thank you, James. I got a similar answer earlier today, and after removing any compatability check-offs was able to download the latest version.