Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox can no longer open PDF files

  • 9 replies
  • 2 have this problem
  • 179 views
  • Last reply by 37MAC73

more options

All of a sudden Firefox can no longer open PDF files. Instead it tries to repeatedly to re-download them. Even when trying opening a PDF file, from my local explorer, into firefox it just tries to re-download the file.

My issue doesn't seem to have anything to do with Firefox Handler options. (It's currently set to "always ask" for PDF files, because if I set it to "preview in Firefox" or "Use Firefox" I just get an infinite loop of tabs trying to re-download the pdf). I've tried deleting the handler.json file, which also did not fix my issue.

Firefox just doesn't seem to be able to view PDF files anymore :/.

I'll try re-installing and report back if that resolves the issue.

All Replies (9)

more options

Re-installing did not fix the issue.

I've attached an image showing the dialogue box which pops up when attempting to open a local PDF file.

clicking 'OK' just proceeds to open another tab with the same dialogue box again.

Modified by Zander46

more options

re-installing and choosing the remove addons option fixed the issue.

more options

Great. Please Mark your Question Solved with Your solution so others can find it.

more options

Aaaand the problem is back again!

This time i've tried disabling all my Add-ons before reinstalling, but it hasn't worked.

So i guess i have to reinstall again...

more options

Is the Firefox PDF Viewer enabled if you check this on the about:config page?

  • about:config?filter=pdfjs
  • pdfjs.disabled = false

You should never select Firefox as the application to handle a file when you get an open with dialog.

For PDF files you can check the setting in "Options/Preferences -> General -> Applications". That should normally be "Preview in Firefox".

You can rename/remove handlers.json and delete mimeTypes.rdf if present in the Firefox profile folder with Firefox closed to reset all file actions.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Modified by cor-el

more options

The same thing is happening to me. I think it is because I checked the do this every time check box the last time I downloaded a PDF file. How do I uncheck the check box? It does not show up anymore. Please help. -MAC

more options

Hi MAC, when you say "the same thing", could you clarify what is happening?

To undo "do this every time," go to the Applications section of the Options/Preferences page and find

Portable Document Format (PDF)

Then select either

  • "Preview in Firefox" to use the built-in viewer (it has a download button its black toolbar)
  • "Always Ask" to always show the Open-or-Save download dialog and bypass the viewer

Note that Firefox only recognizes certain .pdf file as matching those instructions: the server needs to send the application/pdf Content-Type header to trigger your selected preference.

more options

Yes thank you it worked. I scrolled down in the General tab thingy of the about:preferences page and found the files and applications box. I scrolled down in that, found the PDF, and changed it from save file to preview in Firefox. Thanks!!! -MAC

more options

And thank you for your very quick response.