Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How and where can I download a version that still works with Mac OS 10.6.8 (which my old Firefox 3.6.12 does not)?

  • 2 replies
  • 1 has this problem
  • 4 views
  • Last reply by James

more options

I am hoping Firefox will come through where other browsers have not! I cannot upgrade my hardware (iMac 4) or operating system so need a browser that will run on older equipment and software.

Safari 5.1.10 is not working well.

All Replies (2)

more options

Hi, this should work for you, last compatible high security version : Firefox 45.9.0esr will be the most up to date version with security fixes that will run.

Backup :

Please let us know if this solved your issue or if need further assistance.

more options

Fauxtrot said

I am hoping Firefox will come through where other browsers have not! I cannot upgrade my hardware (iMac 4) or operating system so need a browser that will run on older equipment and software.

Mac OSX 10.6, 10.7, 10.8 is EOL as 10.8 was made EOL end of 2015.

Chrome, Chromium, Opera dropped support of the EOL Mac OSX 10.6, 10.7, 10.8 back in April 2016 along with WinXP and Vista.

If not for the Firefox 45 ESR (45.9.0esr released on April 19, 2017) the older Release 48.0.2 out on August 2, 2016 would have been the last updated version to run. Firefox 49.0 and later has required OS X 10.9 and later.

https://support.mozilla.org/en-US/kb/firefox-osx