Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I stop Firefox from autocompleting results in search boxes. This was asked before but solution no longer working.

  • 7 replies
  • 1 has this problem
  • 16 views
  • Last reply by jscher2000

more options

I don't want a list of suggestions when I search in Google search box. The solution was to use this Google Address. This worked for me for years up until a few days ago. Both Internet Explorer and Edge when using this address do not display suggestions. Firefox does all of a sudden.

https://www.google.com/webhp?complete=0

about:config setting for browser.search.suggest.enabled = false

What happened?

Attached screenshots

All Replies (7)

more options

These are generated by the page, so internal Firefox settings for Firefox search boxes do not apply.

That address works for me right now in a private window (so, logged out, no Google cookies). Do you want to try clearing your Google cookies, then load that address again, and see whether that helps? This will log you out of your Google account.

While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Any improvement?

more options

Cleared cookies. No difference. Not logged into Google. I've been using this as homepage https://www.google.com/webhp?complete=0.

The problem only started recently.

more options

I wonder if having it as the home page could possibly be an issue? If you reload the page bypassing the cache -- either

  • Ctrl+Shift+r
  • Shift+click the reload button on the toolbar

-- does that make any difference?


The parameter seems a bit flaky. If I submit this:

https://www.google.com/search?complete=0&hl=en&q=firefox

then type a space after firefox in the search box, there is a list of suggestions for about 2 seconds, then it closes and suggestions stop.

At least, that's what I see this morning... Google is infamous for conducting UI experiments so yours may have been updated in some way.

more options

There is an experiment going on. If I indicate a geo location for other than us, I do not get suggestions

Canada, Australia, Germany https://www.google.com/?gl=ca&complete=0 https://www.google.com/?gl=au&complete=0 https://www.google.com/?gl=de&complete=0

If I indicate US https://www.google.com/?gl=us&complete=0 OR https://www.google.com/?&complete=0

I get the unwanted suggestions.

Internet Explorer and Edge, which I abandoned for Firefox last year do what is expected with these parameters, not Firefox. That's why I see this as a Firefox problem even if instigated by Google

more options

eastwezt said

Internet Explorer and Edge, which I abandoned for Firefox last year do what is expected with these parameters, not Firefox. That's why I see this as a Firefox problem even if instigated by Google

Actually, Firefox doesn't do anything with the parameters between the ? and any # in the URL. The "search" portion of the URL that starts with ? is is for the site to determine what content it sends, and on some sites, for scripts in the page to decide how to behave. The # mark (if any) functions as a "bookmark" within a page and triggers Firefox to scroll to that position (although it can have other uses on sites with a modern design).

Is this problem linked to when New Tab Override substitutes that URL for the built-in new tab page? In other words, if you just click https://www.google.com/webhp?complete=0&hl=en from my post, or open it using a bookmark, does it work like it used to?

more options

I learned something new. I suspected that my new Google/Gmail account may have something to do with this recent problem. When I am logged into Google, the search using this parameter is correct without suggestions.

https://www.google.com/webhp?complete=0

If I am not logged into Google, the same search parameter gives me the unwanted suggestions.

Something to do with Google tracking searches? I don't know what to do next. The suggestions are annoyyyyying.

more options

It's possible to hide the drop-down using an add-on, but there will still be that traffic in the background, so that's not ideal. If no one comes up with something better, I'll look into something along those lines.

Modified by jscher2000