Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

unable to navigate while downloading at high speed

  • 33 replies
  • 1 has this problem
  • 91 views
  • Last reply by lyamine

more options

Hi,

I don't understand what's wrong with the browser, I already signaled my disappointment as a feedback. As all reported, the browser is freezing sometime when I open a new tab (especially after an update). I have to restart at least 2 times the browser to make it works. This is not the big problem.

The pain point is that I cannot navigate while I am downloading a file at a high speed (120Mb/s). This is not due to my router or what ever in my computer but related to Firefox. While Firefox is downloading, I can use Edge without any issue.

I tried the same action in safe mode and I got the same problem.

Could you please tell me how to resolve this problem?

Is there a workaround if it's a bug?

Thank you.


Regards, Lyamine

All Replies (13)

more options

Pkshadow said

Not sure what your downloading but I tend to use things that like to go faster so you may want to look into these : Can also use the search from the URL and just need download as a search word.

If the download has a limited bandwidth (by the server), let’s say 500KB, there is no problem to load pages. I don’t want to add plugins unfortunately, I would like to use the browser as clean as possible ;)

more options

Now windows is cleaning the ssd. So long due to windows update cleanup...

more options

You can get both of those as stand alone programs also, plus iGetter is good but tends to be a right click and copy url location, paste.

more options

Ya, I stick that in there as a lot of people do not know what it is for or exists so nothing ever gets cleaned.

If do not use Sessions you can triple what this guy suggests. https://www.servethehome.com/firefox-is-eating-your-ssd-here-is-how-to-fix-it/ As for what they have to say about SSD's, mine are 5yrs old no errors.

more options
more options

I don’t have any issue with the sad lol. It’s just windows that is cleaning the cumulative updates downloaded. Now it’s done. Let’s try with a fresh FF

more options

Ya, I did not think so but it reduces the read/write to the disk by a lot of megs per day which means ram is doing something else when you might need it.

more options

So, I tried with a fresh installation. Without any addons and same issue :/

more options
more options

Well, investigate into that a little and get back to us. Sorry that did not work out but you did get cleaned..lol

more options
more options

Pkshadow said

Well, investigate into that a little and get back to us. Sorry that did not work out but you did get cleaned..lol

I am investigating the issue. I want to thank you for your time anyways. I will be back when I have more details ;)

more options

Strangely it happens only on mp4 files and especially through Internet. if I download a file from local area Web server and navigate on Internet, no problem.

Using Fiddler I noticed that the request is gone, I suspected my Asus Router so I disabled and re-enbled AiProtection and sites are loading, the speed depends on the contents to load though. it's very slow but it's not in pending anymore.

I will check that when I have time

  1. 1
  2. 2