Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bookmarks are gone from the bar

  • 15 replies
  • 1 has this problem
  • 115 views
  • Last reply by Coder_Fox

more options

After synchronizing my firefox account on a ubuntu machine my windows firefox removed my bookmarks from the area near the search bar and now trying to place them from the bookmark sidebar doesn't do anything. Is there a way to fix this?

Modified by Coder_Fox

Chosen solution

Hi Coder_Fox, can you try going to Customize, and then selecting Restore Defaults?

We're a little concerned that the toolbar elements might not be quite the right place, or there may be an extra spacer that is making them not display correctly. Doing a restore default should make sure we're in the right place.

Also I'm attaching an image of what toolbars look like in customize mode, in case that helps.

Read this answer in context 👍 0

All Replies (15)

more options

Here is a screenshot.

more options

Separate Security Issue, please update your Flash 28.0 r0 by removing it If you use it Reinstall with Flash Player Version: 30.0.0.134 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Please try in Safe Mode :

more options

Coder_Fox said

... now trying to place them from the bookmark sidebar doesn't do anything. Is there a way to fix this?

{Ctrl + Shft + B} to open the Library window. Move those bookmarks into the Bookmarks Toolbar folder when you're viewing your bookmarks in the Library window.

more options

Pkshadow said

Separate Security Issue, please update your Flash 28.0 r0 by removing it If you use it Reinstall with Flash Player Version: 30.0.0.134 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only> Please try in Safe Mode :

I removed Flash at all and tried safe mode but nothing helped.

more options

the-edmeister said

Coder_Fox said
... now trying to place them from the bookmark sidebar doesn't do anything. Is there a way to fix this?

{Ctrl + Shft + B} to open the Library window. Move those bookmarks into the Bookmarks Toolbar folder when you're viewing your bookmarks in the Library window.

They are already there.

more options

Hard to tell with that dark theme, but is the Bookmarks Toolbar showing in Firefox on Windows 10?

Also, have you done any userChrome.css mods to that Firefox installation?

more options

the-edmeister said

Also, have you done any userChrome.css mods to that Firefox installation?

No.

more options

Hi, please can you try this:

Open the 3-bar menu > Help > Troubleshooting Information. That will load a page in your browser, then near the bottom look for Places Database and click on Verify Integrity.

That should run some checks, and there hopefully won't be any errors raised.

Then restart Firefox and see if the toolbar starts working properly again.

Please let us know either way.

more options

Standard8 said

Please let us know either way.

Nothing changed.

 Here is what the console spitted out:

> Task: checkIntegrity + The database is sane > Task: invalidateCaches + The caches have been invalidated > Task: checkCoherence + The database is coherent > Task: expire + Database cleaned up > Task: vacuum + Initial database size is 10240KiB + The database has been vacuumed + Final database size is 10240KiB > Task: stats + Places.sqlite size is 10240KiB + Favicons.sqlite size is 10400KiB + pragma_user_version is 47 + pragma_page_size is 32768 + pragma_cache_size is -2048 + pragma_journal_mode is wal + pragma_synchronous is 1 + History can store a maximum of 136179 unique pages + Table moz_places has 15341 records + Table moz_historyvisits has 21175 records + Table moz_inputhistory has 43 records + Table moz_hosts has 1663 records + Table moz_bookmarks has 166 records + Table moz_bookmarks_deleted has 0 records + Table moz_keywords has 0 records + Table sqlite_sequence has 0 records + Table moz_anno_attributes has 6 records + Table moz_annos has 201 records + Table moz_items_annos has 16 records + Table sqlite_stat1 has 17 records + Table moz_meta has 4 records + Index sqlite_autoindex_moz_inputhistory_1 + Index sqlite_autoindex_moz_hosts_1 + Index sqlite_autoindex_moz_bookmarks_deleted_1 + Index sqlite_autoindex_moz_keywords_1 + Index sqlite_autoindex_moz_anno_attributes_1 + Index moz_places_url_hashindex + Index moz_places_hostindex + Index moz_places_visitcount + Index moz_places_frecencyindex + Index moz_places_lastvisitdateindex + Index moz_places_guid_uniqueindex + Index moz_historyvisits_placedateindex + Index moz_historyvisits_fromindex + Index moz_historyvisits_dateindex + Index moz_bookmarks_itemindex + Index moz_bookmarks_parentindex + Index moz_bookmarks_itemlastmodifiedindex + Index moz_bookmarks_dateaddedindex + Index moz_bookmarks_guid_uniqueindex + Index moz_keywords_placepostdata_uniqueindex + Index moz_annos_placeattributeindex + Index moz_items_annos_itemattributeindex > Task: _refreshUI

Modified by Coder_Fox

more options

Ok, your database looks good, and presumably you restarted Firefox.

Please check that View -> Toolbars -> Bookmarks Toolbar is checked.

I'd also suggest going to the three-bar menu, selecting "Customize..." and then see if "Bookmarks Toolbar Items" appears in the toolbar where you expect.

If it does, you can just click "Done" to exit, or you can try and find it and put it where you expect.

If that doesn't work, try restarting Firefox, and as soon as it has loaded, open the Browser Console window via three-bar menu -> Web Developer -> Browser Console, and see if there's any errors appearing on there (especially related to "places" or "bookmarks").

more options

Standard8 said

Please check that View -> Toolbars -> Bookmarks Toolbar is checked.

They are enabled. Standard8 said

I'd also suggest going to the three-bar menu, selecting "Customize..." and then see if "Bookmarks Toolbar Items" appears in the toolbar where you expect.

It's there. (It looks like a blank space without any bookmarks) I tried to put some stuff in there and it appeared, but bookmarks still don't appear.

If that doesn't work, try restarting Firefox, and as soon as it has loaded, open the Browser Console window via three-bar menu -> Web Developer -> Browser Console, and see if there's any errors appearing on there (especially related to "places" or "bookmarks").

No errors there.

more options

Chosen Solution

Hi Coder_Fox, can you try going to Customize, and then selecting Restore Defaults?

We're a little concerned that the toolbar elements might not be quite the right place, or there may be an extra spacer that is making them not display correctly. Doing a restore default should make sure we're in the right place.

Also I'm attaching an image of what toolbars look like in customize mode, in case that helps.

more options

Just a thought, could you also go to File -> New Private Window, and see if the toolbar is shown correctly in private browsing mode?

more options

Or did my previous suggestion work?

more options

Standard8 said

Or did my previous suggestion work?

Yes, it did.