X
Tap here to go to the mobile version of the site.

Safely share files online with encrypted links that “self-destruct.” Try Firefox Send.

Give hackers a swift kick in the cookies. See if your data has been affected by a breach with Firefox Monitor. Try it now.

Access your history, passwords and open tabs wherever you are with Sync. Connect a second device.

Support Forum

Edited moz_places.url now blue star for updated rows is missing

Posted

Background: I wanted to update all occurances of http:// with https:// for a specific domain. I updated places.sqlite moz_places.url column. Everything went well, bookmarks were synced and propagated among devices.

Caveat: Simulataneously I did one more modification and I'm not sure what. I'm sorry for lack of specifics. Probably updated moz_bookmarks.lastModified to ensure syncing?

Problem: Now when I type phrase into site bar a url is suggested, star is marked, but when I wisit the page and close suggestion list star is empty. This happens only for modified urls.

Question: Can you help me with solving this problem? I will appreciate any suggestion where to find the solution.

Thank you very much, Joe


edit: - typo

Background: I wanted to update all occurances of http:// with https:// for a specific domain. I updated places.sqlite moz_places.url column. Everything went well, bookmarks were synced and propagated among devices. Caveat: Simulataneously I did one more modification and I'm not sure what. I'm sorry for lack of specifics. Probably updated moz_bookmarks.lastModified to ensure syncing? Problem: Now when I type phrase into site bar a url is suggested, star is marked, but when I wisit the page and close suggestion list star is empty. This happens only for modified urls. Question: Can you help me with solving this problem? I will appreciate any suggestion where to find the solution. Thank you very much, Joe edit: - typo
Attached screenshots

Modified by joesmith007

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

More Information

the-edmeister
  • Top 25 Contributor
  • Moderator
5359 solutions 39789 answers

You probably need to edit those bookmarks so that they have the https protocol rather than http.

You probably need to edit those bookmarks so that they have the https protocol rather than http.

Question owner

the-edmeister said

You probably need to edit those bookmarks so that they have the https protocol rather than http.

Thank you for reply @the-edmeister. I'm affraid we're not on the same page. If my question is unclear please give me a suggestion and I'll try to be more specific. I automatically edited all bookmarks as I wished. Unfortunatelly issue with missing blue star araised after this modification.

I can only conjecture there is some kind of logic based on other than moz_places.url column e.g. based on url_hash for efficiency. Additionally i edited one of affected bookmarks by hand to check if "something" isn't overwritten, but no - it doesn't fix the issue.

''the-edmeister [[#answer-1142228|said]]'' <blockquote> You probably need to edit those bookmarks so that they have the https protocol rather than http. </blockquote> Thank you for reply @the-edmeister. I'm affraid we're not on the same page. If my question is unclear please give me a suggestion and I'll try to be more specific. I automatically edited all bookmarks as I wished. Unfortunatelly issue with missing blue star araised after this modification. I can only conjecture there is some kind of logic based on other than moz_places.url column e.g. based on url_hash for efficiency. Additionally i edited one of affected bookmarks by hand to check if "something" isn't overwritten, but no - it doesn't fix the issue.