Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to delete YouTube sites

  • 2 replies
  • 1 has this problem
  • 65 views
  • Last reply by walsh-5

more options

Some YouTube sites come up when I try to select a website. How can I delete them? Everything I try just opens them.

Chosen solution

(I think your question is for a Mac, and not for a phone running FirefoxOS. Please correct me if I'm wrong.)

Do mean, for example, you put Google in the address bar and press Return, and you get a page on YouTube?

Or you are looking at some search results, you click a link, and instead of the expected site, you get a page on YouTube?

Does it seem to be some kind of advertising??


Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

(I think your question is for a Mac, and not for a phone running FirefoxOS. Please correct me if I'm wrong.)

Do mean, for example, you put Google in the address bar and press Return, and you get a page on YouTube?

Or you are looking at some search results, you click a link, and instead of the expected site, you get a page on YouTube?

Does it seem to be some kind of advertising??


Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Thanks. I found the answer to my problem in the HELP.