Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't change the default account to a new default email

  • 12 replies
  • 1 has this problem
  • 35 views
  • Last reply by Toad-Hall

more options

I have a single profile that has 8 accounts (all SMTP email accounts on my own server), each has its own smtp account. I need to change the default account but it will not change. Tried rebooting as well.

The one I want to change to is set as the default. And when I create a New Message the reply to is using the original email address. If I click the reply to drop down the one I want is set to the 1st entry as the default, but its the 2nd entry that keeps populating for all new messages.

How do I get it to set the reply to address to be the 1st one in the drop down?

Using the current version of Thunderbird on Windows 10

All Replies (12)

more options

The default account will appear at the top of both Account Settings window and Folder Pane.

If you are viewing an email or folder which is in a different account (not the default account) and then you click on 'Write' or 'Reply', that mail accounts email address will be placed in the 'From' field because TB assumes if you are viewing a particular account then you will more than likely be creating an email or reponding to an email which is about the account you are viewing.

If you are viewing email or folder in the default mail account then it will use the default email address in the From field.

Modified by Toad-Hall

more options

To set an account as default.

  • Right click on any mail account and select 'Settings'

The account listed at the top will already be default. If you select it and click on 'Account Actions', the 'Set as default' option will be greyed out because it is already the default account.

To choose another account as default:

  • select the name of the mail account you want to be default.
  • Click on 'Account Actions'
  • Select 'Set as default'
  • click on OK

That account will be moved to the top of the list and will be the default account.

more options

Sorry but that does not fix the problem.

When I sent myself a test message from the new email address that I want to be the one that populates all New Messages from and I have that email selected at the currently viewed message.

Then I select New Message it still populates the from email using the old account that is the 2nd one down the account list and not the default and not the one from the message selected.

I originally setup Thunderbird to use an email account XXX@cyber-sea.com and I had 7 other accounts for other SMTP emails. YYY@proposalkit.com is my 2nd account on the list.

I changed YYY@proposalkit.com to be the default account and it is displaying as the 1st account on the drop down list for each New Message.

But every time I create a New Message it populates the from as XXX@cyber-sea.com.

I sent myself test messages from YYY@proposalkit.com then selected that as the currently viewed email and did a New Message and it still populates the from as XXX@cyber-sea.com

I'm transitioning all my outgoing emails to be from a new company name but I can't get T.B. to use the new company account.

Is there a database setting or a registry setting I can tweak manually to get this working?

more options

re :I sent myself test messages from YYY@proposalkit.com But you do not say which account it was sent to

Send email TO YYY@proposalkit.com So it is incoming into YYY@proposalkit.com mail account. then select that email now click on Write What is in FROM ?

more options

That didn't work. See attached screenshot. I deleted everything in my inbox except your last reply. Sent myself another test email from and to xxx@proposalkit.com

Hightlighted that test message and selected New Message and it populates with yyy@cyber-sea.com (the 2nd email in the list).

more options

The image (top left corner) shows you are currently selecting the Inbox for Cyber-sea. So it will 'Reply' or 'Write' using the Cyber-sea email address.

Do you have proposalkit emails being redirected into Cyber-sea Inbox?

Please post info: Help > Troubleshooting Information Do Not select checkbox 'Include account names' click on 'Copy text to clipboard' In this forum question, right click in a 'Post a Reply' text box and select 'Paste'. You can remove/edit all info regarding fonts and printers but do not alter anything else.

more options

Okay, I only have 1 inbox then. All my emails from all 7 SMTP accounts just go into one inbox. Where do I change the inbox settings?

Its not a complicated setup I'm trying to do. I have 1 profile, I have 7 email addresses on the account. I only need 1 inbox/trash/junk folder that everything goes into. All I'm trying to do is get it to use a different one of those emails in the account as the default.

All I want to do is change it from CyberSea to ProposalKit.

I can't find any settings for changing the inbox to use a different email (the new default). Where do you change that?

I have 7 accounts listed. CyberSea is no longer the default. ProposalKit is now the default. But there are no options I see in the account settings that tie these to the inbox. How do I change the Inbox to say ProposalKit and use that default email?

more options

This is getting to be too much of a pain to fixup through the interface. The easiest solution seems to be to just change the actual email address and signature on the CyberSea account to copy from the default ProposalKit account.

Then I'll have to add a new CyberSea2 account with that old address back in so those emails will still flow into the inbox. But all my new messages no matter what might be selected will use the email address I want used for new messages.

Just changing all the defaults isn't working.

more options

You repeatedly refer to these as "smtp accounts". That's rather unusual. Most users are concerned primarily with their incoming account, barely registering that each needs an smtp account to allow it to send. And in many cases, the smtp account used to send the message has no bearing on the "from:" address that appears in the sent message. (Gmail is a notable exception, where the sending smtp account's address is silently substituted, replacing whatever was put into the message at the time of its composition.)

The "Default Address" concept in Thunderbird is very much tied to incoming (POP/IMAP) accounts. And Thunderbird (in general) allows you to use only the installed incoming account addresses as "from:" addresses. (Actually, a recent change was to allow the "from:" address to be arbitrarily changed. In most cases this is a nuisance because usually the smtp server will reject an unknown "from:" address.)

I would advise you to set up each address as an incoming POP or IMAP account, then the default thing should start to work. If you don't want or can't do this, it may be workable to set them up as additional identities of an existing incoming account.

IMHO, it's much better to use the actual address as the "from:" address than to rely on a "reply-to:" address, as you seem to be doing. The "from:" address is what people see in their Inbox listings; the "reply-to;" address is hidden inside the message. If you're running multiple businesses then the "from:" is all-important. Seeing a different "reply-to:" address would always leave me with an uneasy sense that things were not as they appeared, and I'd probably do some whois lookups before trusting it.

more options

They are POP accounts. I mentioned SMTP by mistake because that was what was showing up on the accounts.

Frankly I fixed the whole thing to get it working the way I wanted by simply swapping the account information between the two POP accounts and renaming them. In the end I still have a ProposalKit account and a CyberSea account, but they are just reversed now in the accounts and its doing what I wanted. Just a convoluted way of getting it working.

Maybe I could have got it working better by redoing the global inbox, but its been years since I set up Thunderbird and messed with the accounts and forgot there was a global inbox. Its hidden enough in the account settings it took all this time to run across it again.

It seems to be all tied to using a single global inbox between the accounts and even after changing the default email account it still wouldnt just create new messages from the default account.

more options

The default account is the clanger as it is only relevant when there is no account selected in the folder pane. Particularly relevant if Thunderbird is not running when a mailto link is clicked or MAPI is initiated. Otherwise rarely does it come into play.

more options

As all your accounts are set up as POP, you could try using a Global Inbox which is the 'Local Folders' mail account Inbox instead of a particular mail account Inbox.

Read some info here: http://kb.mozillazine.org/Global_Inbox