Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Videos on Youtube have green blocks/artifacts all over them which makes them unwatchable

  • 24 replies
  • 1 has this problem
  • 106 views
  • Last reply by McCoy

more options

See screenshots. A detail that may or may not be related: I have disabled cache from about:config (browser.cache.disk.enable and browser.cache.memory.enable) because enabling these makes Firefox crash as soon as it is opened (https://support.mozilla.org/en-US/questions/1180306).

Also this issue happens on Chrome as well, but does not happen on Microsoft Edge browser.

Things I have already tried: 1. Enable/disable hardware acceleration 2. Update gpu drivers to latest 3. Switch between the onboard gpu (Intel HD 4600) and discrete (Nvidia 840M) 4. Refresh Firefox <-- the first video on Youtube plays fine after refreshing Firefox, but after this the problem is back. 5. Disable all add-ons/try safe mode 6. Try the suggestions from Fixing common audio/video issues page (https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues) and other related pages that I was suggested when I entered this question.

None of these solutions have worked. Appreciate any help/ideas. Thanks!

Attached screenshots

All Replies (20)

more options

When you reinstalled FF did you uninstall all FF and deleted Mozilla folder before reinstall? Are the videos problems only on Youtube?

more options

WestEnd said

When you reinstalled FF did you uninstall all FF and deleted Mozilla folder before reinstall? Are the videos problems only on Youtube?

Yes and yes.

more options

I also scanned the computer for any malware/virus using several different antivirus/antimalware solutions. Nothing found.

more options

Separate Security Issue, please update your Flash 27.0 r0 by removing it with this tool : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html If you use it Reinstall with Flash Player Version: 30.0.0.134 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Hi, reply back so this gets on the board again as I think the root of your issue is to figure out why your crashing before this artifact stuff happened.

Please look for a crash report dated before you made the changes in about:config or undo those changes, and crash it please. Then include the bp- as in the picture below and only need up to 5 of crash reports.

The crash report is several pages of data. We need the report numbers to see the whole report.

  1. Enter about:crashes in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below.
  2. Copy the 5 most recent Report IDs that start with bp- and then go back to your forum question and paste those IDs into the "Post a Reply" box.

Note: If a recent Report ID does not start with bp- click on it to submit the report.

(Please don't take a screenshot of your crashes, just copy and paste the IDs. The below image is just an example of what your Firefox screen should look like.)

aboutcrashesFx57

Thank you for your help!

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

more options

Thank you, Pkshadow. Here are the report id's as requested:

bp-8f34f18d-797f-45ad-836a-9f1c90180722 bp-5387d50f-8466-4b46-92e3-caf9a0180722 bp-c3516e89-79de-4cb3-b489-3fd3f0180722 bp-5137132b-1daf-4426-a346-7f9d70180722 bp-d473bb1e-cd1a-4842-87ed-372220180722

more options

Hi, is there any update on this issue? Here is a new thing I observed - when I restart the computer in safe mode, the videos play fine.

Appreciate any help!

more options

Hi, sorry you seem to have got lost with no one else seeing you there. Good you messaged as you were right off the board. Ok so it works in Safe Mode. When in that below is what happens and what you also need to check.

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

See if any thing comes of this above by checking the Extensions. Also Hardware Acceleration (Video Card) is turned off above so : https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

In final desperation as the crash reports state some corruption. Let's try a reinstall : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 61.0.1 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

more options

Just to clarify - it works when the computer is in safe mode, not Firefox. I'm trying a full uninstall/reinstall right now and will report the results.

more options

If runs in Windows Safe Mode then big issues.

Drivers. Please try to find updated drivers as artifacts are Video Card/Driver related.

Please do this also : Using DISM with the RestoreHearlh option

Use the DISM command with the /RestoreHealth switch to scan the Windows image for any corruption and to perform a repair automatically. Unlike the /ScanHealth switch, the /RestoreHealth switch can take up to 20 minutes to complete the process.

To run the command do the following: 1)Use the Windows key + X keyboard shortcut to open the Power User menu and select Command Prompt (Admin). 2)Copy/Paste the following command and press Enter: DISM /Online /Cleanup-Image /RestoreHealth

Reboot after .

more options

Thanks for keeping up Pkshadow. So here's the update: I fully uninstalled FIrefox, including cleaning up all the folders. I then ran the DISM command, followed by SFC command twice. Then I reinstalled Firefox.

The issue still remains... :( I am running out of ideas.

more options

rufatagayev said

The issue still remains... :( I am running out of ideas.

Must be really frustrating .....

Would you please try this :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar media.wmf.dxva.d3d11.enabled

And set its value to false

Then close and restart Firefox.

Does this make a difference  ?

more options

Yes, it is frustrating.

I have already tried your suggestion, but it did not help. I am now checking the computer memory for wny errors, but I am open to any other ideas.

more options

This is not going to help, but I wanted you to see this, cause it sounds like this user could be you :

https://www.reddit.com/r/firefox/comments/86l9ao/green_blocksartifacts_when_playing_youtube_videos/

Just like with you, for this user it not only happens using Firefox, but also in Chrome.

Remarkable, eh  ?

more options

Yes, that is me :)

more options

rufatagayev said

Yes, that is me :)

Wow  ! You've been dealing with this for quite some time  !

You will undoubtedly have done this, but just to make absolutely sure :

After you've made a change, whether in Options or on the 'about:config' page : did you then close and restart Firefox, in order for the change to take effect  ?

And that preference that I wanted you to change on the 'about:config' page : are you sure that you tried the exact same preference before  ?

more options

McCoy said

did you then close and restart Firefox

Yes

are you sure that you tried the exact same preference before

Yes. And not only that, I also tried disabling media.wmf.dxva.enabled as well, but it did not help.

I also ran memory diagnostics last night to see if there is anything wrong with the memory, but nothing came up. Looking for more options.

more options

Even though you may already know all about Windows in Safe Mode - maybe, just maybe, if you go over this article, you'll get this "Aha"
moment .....

https://computer.howstuffworks.com/question575.htm

The answer just has to be there, somewhere (as the problem is gone with Windows in Safe Mode) ....

more options

Thank you for the suggestion McCoy, but that link is already purple for me :) Still looking for that "aha" moment and keeping that page open as well.

more options

Couldn't let it go and found this :

https://www.youtube.com/watch?v=drmHlD642XE

Any good  ?

more options

Thanks again, but that video is old. Youtube does not use flash video nowadays. Still, thanks for suggesting.

  1. 1
  2. 2