X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Secure Connection Failed - error code not mentioned here

Posted

This error started cropping up lately, more and more: SSL_ERROR_NO_CYPHER_OVERLAP Since a couple of weeks ago I can't use one of my bank services with FF (even safe mode, no addons), but Chrome doesn't complain.

Main complaint is: this error isn't mentioned in the "Learn more…" link offered on the error page. Secondary (by not much) is: it isn't mentioned anywhere else either.

I really have searched, time and again (as in "lately" above, couple of months) hoping perhaps someone would post something helpful. Perhaps then this could be it.

Secure Connection Failed
An error occurred during a connection to ubs.cardcenter.ch. Cannot communicate securely with peer: no common encryption algorithm(s). Error code: SSL_ERROR_NO_CYPHER_OVERLAP
    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    Please contact the website owners to inform them of this problem.
Learn more… <https://support.mozilla.org/en-US/kb/what-does-your-connection-is-not-secure-mean>
Report errors like this to help Mozilla identify and block malicious sites

https://support.mozilla.org/en-US/kb/what-does-your-connection-is-not-secure-mean … doesn't mention this error. How to troubleshoot "Your connection is not secure" error codes on secure websites. <https://support.mozilla.org/en-US/kb/error-codes-secure-websites> Also doesn't mention this error.

No help here: https://support.mozilla.org/en-US/questions/1214366 (or any other of the 5 search hits for this error)

https://www.ssllabs.com/ssltest/viewMyClient.html TLS compression NO SSL 2 handshake compatibility NO … else all green.

Anybody out there? Any help?

This error started cropping up lately, more and more: SSL_ERROR_NO_CYPHER_OVERLAP Since a couple of weeks ago I can't use one of my bank services with FF (even safe mode, no addons), but Chrome doesn't complain. Main complaint is: this error isn't mentioned in the "Learn more…" link offered on the error page. Secondary (by not much) is: it isn't mentioned anywhere else either. I really have searched, time and again (as in "lately" above, couple of months) hoping perhaps someone would post something helpful. Perhaps then this could be it. <pre> Secure Connection Failed An error occurred during a connection to ubs.cardcenter.ch. Cannot communicate securely with peer: no common encryption algorithm(s). Error code: SSL_ERROR_NO_CYPHER_OVERLAP The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem. Learn more… <https://support.mozilla.org/en-US/kb/what-does-your-connection-is-not-secure-mean> Report errors like this to help Mozilla identify and block malicious sites </pre> https://support.mozilla.org/en-US/kb/what-does-your-connection-is-not-secure-mean … doesn't mention this error. How to troubleshoot "Your connection is not secure" error codes on secure websites. <https://support.mozilla.org/en-US/kb/error-codes-secure-websites> Also doesn't mention this error. No help here: https://support.mozilla.org/en-US/questions/1214366 (or any other of the 5 search hits for this error) https://www.ssllabs.com/ssltest/viewMyClient.html TLS compression NO SSL 2 handshake compatibility NO … else all green. Anybody out there? Any help?

Additional System Details

Application

  • Firefox 60.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
  • Support URL: https://support.mozilla.org/1/firefox/60.0.2/WINNT/en-US/

Extensions

  • AutocopySelection2Clipboard 2.6.0 (autocopyselection2clipboard@dook) (Inactive)
  • Enable Right Click and Copy 2017.4.12 (enable-right-click-and-copy@afnankhan) (Inactive)
  • Enhancer for YouTube™ 2.0.72 (enhancerforyoutube@maximerf.addons.mozilla.org) (Inactive)
  • Facebook Container 1.3.1 (@contain-facebook) (Inactive)
  • Ghostery – Privacy Ad Blocker 8.2.0 (firefox@ghostery.com) (Inactive)
  • Google search link fix 1.6.7 (jid0-XWJxt5VvCXkKzQK99PhZqAn7Xbg@jetpack) (Inactive)
  • Happy Right-Click 1.1.0 ({dd10d63e-3096-4492-ab0e-5edcf4baf988}) (Inactive)
  • Print Edit WE 22.1 (printedit-we@DW-dev) (Inactive)
  • ScriptSafe 1.0.9.8 (scriptsafe@protonmail.com) (Inactive)
  • ScrollAnywhere 6.0 (juraj.masiar@gmail.com_ScrollAnywhere) (Inactive)
  • Social Fixer for Facebook 22.0.0 (betterfacebook@mattkruse.com) (Inactive)
  • Tab Mix WebExtension 0.0.1 (webext@tabmixplus.org) (Inactive)
  • uBlock Origin 1.16.12 (uBlock0@raymondhill.net) (Inactive)
  • Unpaywall 3.77 ({f209234a-76f0-4735-9920-eb62507a54cd}) (Inactive)
  • Video DownloadHelper 7.3.1 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 6800 Series
  • adapterDescription2:
  • adapterDeviceID: 0x6738
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 00d01002
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2,6 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
  • crashGuards: []
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.22164
  • driverDate: 4-19-2011
  • driverDate2:
  • driverVersion: 8.850.0.0
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Acceleration blocked by safe-mode', u'type': u'runtime'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'blocked', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Safe-mode is enabled', u'type': u'runtime'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u'ANGLE is disabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'OMTP blocked by safe-mode', u'type': u'runtime'}], u'name': u'OMTP'}]}
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'cairo', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: False
  • offMainThreadPaintWorkerCount: 0
  • usesTiling: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: Yes
Shadow110 1072 solutions 14836 answers

HI, what Security Program are you running please ?

Please update your Video Card Drivers they are full of errors with stuff not working or are disabled. Some of that maybe because you were in Safe Mode when you supplied the information. I gather no changes for you in Safe Mode then....

adapterDescription: AMD Radeon HD 6800 Series driverDate: 4-19-2011 I would suggest running the Crimson Drivers and Download the both for storage as no more updates. These drivers are from 2015 & 16 https://support.amd.com/en-us/download/desktop/legacy?product=legacy3&os=Windows%2010%20-%2064

HI, what Security Program are you running please ? Please update your Video Card Drivers they are full of errors with stuff not working or are disabled. Some of that maybe because you were in Safe Mode when you supplied the information. I gather no changes for you in Safe Mode then.... adapterDescription: AMD Radeon HD 6800 Series driverDate: 4-19-2011 I would suggest running the Crimson Drivers and Download the both for storage as no more updates. These drivers are from 2015 & 16 https://support.amd.com/en-us/download/desktop/legacy?product=legacy3&os=Windows%2010%20-%2064
Shadow110 1072 solutions 14836 answers

Can you check your Device Manager for the name of your Network Card and version please. Look around for a new set of drivers. As the old drivers for video card are from 2011 I would guess that the same holds for the Network card. It may not be able to handle the TLS in it's current state.

Can you check your Device Manager for the name of your Network Card and version please. Look around for a new set of drivers. As the old drivers for video card are from 2011 I would guess that the same holds for the Network card. It may not be able to handle the TLS in it's current state.