Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is displaying oddly. i.e. no borders around search fields, no pictures

  • 16 replies
  • 1 has this problem
  • 26 views
  • Last reply by cor-el

more options

Not sure when this started - i.e. with a recent windows update or with a mozilla update. I have tried to resync mozilla too.

See attached image - basically on starting mozilla/google I do not have any borders showing for the search fields and no pictures show up - I thought at first it might be "Pocket" related but attached image is with Pocket Disabled... This I believe was working absolutely fine yesterday - though I didn't use the computer for anything other than flying P3D.

Can someone kindly help me with this?

All Replies (16)

more options

Hi, please check that it is not new Tab Override causing the issue by disabling it, Restart Firefox. If it is not please try this : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 61.0.1 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

more options

Make sure you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure you allow pages to choose their own colors.

  • Options/Preferences -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

more options

Tried both suggestions. The search bar is still transparent, so one cannot see a border. Also top sites are highlighted with an uppercase letter for each topic i.e. L for Linked In.....most annoying. If this the new Mozilla, I'm out, after being an avid supporter for years.

more options

Can you attach a screenshot?

more options

Attached you will see the following:

1) No border around search area 2) No Pictures 3) Annoying Capitalized Letters outlining last page visits.

I am not a fan of the latest iteration of firefox - it seems too commercial and that's not what I wanted in a search engine.

Please help at least, to restore images and search box borders and perhaps I can grow into this.

more options

The screenshot would suggest a problem with the color setting like I posted above.

Can you show a screenshot that shows the browser.display*color prefs on the about:config page?

more options

See below... I never touched anything in here.. I don't even know what this is and had to google what you were explaining to me...

more options

You need to set browser.display.document_color_use either to 1 or 0.

  • 2 means override: "Always" and this disables website colors and background images
  • 1 means override: "Never"
  • 0 is the default: "Only with High Contrast themes"
  • Options/Preferences -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

more options

See attached. The screen still looks like above image. 1) no pictures 2) No search bar border 3) Silly Upper Case

more options

Does the problem only occur on the built-in home page and/or new tab page, or is it affecting all sites?

more options

As you can see in the attached - after typing in CNN in the hard to see search bar... it is on other pages as well. Yet if you Microsoft Edge...it's as it should be.

more options

Hmm, the only built-in setting that I know can do that is the one you already changed:

  • browser.display.document_color_use => 2 or
  • browser.display.document_color_use => 0 if you use a high contrast theme

browser.display.document_color_use => 1 should use the colors specified by the site.

Could you try:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. It's not essential to uninstall Firefox, but you can if you like, saying No to any request about removing personal data.

It only takes a few minutes.

(A) Download a fresh installer for Firefox to a convenient location:

https://www.mozilla.org/firefox/all/

(B) Exit out of Firefox (if applicable).

If you use Microsoft Office, please change your default browser to Internet Explorer before the next step.

(C) Using Windows Explorer/My Computer (hold down the Windows key and press E), right-click > rename the program folder as follows (you might have one or both):

C:\Program Files (x86)\Mozilla Firefox =to=> C:\Program Files (x86)\OldFirefox

C:\Program Files\Mozilla Firefox =to=> C:\Program Files\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Any improvement?

more options

Sorry...that never worked as well. After trying that I uninstalled firefox, and all registry entries etc., using irobot uninstaller, and redownloaded to yield no change. Not impressed. Appreciate the insights though

more options

I'm not familar with irobot uninstaller. Did it effectively remove the old installation folder?

Perhaps there is some setting that is not coming to mind. To compare a clean install:

New Profile Test

This takes about 3 minutes, plus the time to test a few sites.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like July2018, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new. Please ignore any suggestion to connect to a Sync account or activate extensions to get a clean test.

Do sites appear normal in the new profile? If you switch the Color setting from 0 to 1, does that make any difference in the new profile?

When you are done with the experiment, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

more options

Sorry that never worked as well.... Really odd issue. I've tried each of the above solutions. Doubtful that its related to anything I have done in side of my Nvidia settings for display but will look at this too....

more options

Did you verify that browser.display.document_color_use is still 1 (or 0) and not 2?

The screenshot doesn't show browser.display.use_system_colors (it would have been included if you had used browser.display*color in the search bar), so check that one as well. --- You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Modified by cor-el