Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot Access Linkedin.com with Firefox.

  • 4 replies
  • 1 has this problem
  • 15 views
  • Last reply by shannonphx

more options

I'm using Firefox 52.9.0 for Mac. A couple weeks ago I began having problems accessing LinkedIn.com (never had issues prior to this).

• I have no problems accessing LinkedIn.com with Chrome or Safari.

• NO new Add Ons have been installed.

• I do NOT access the site with a bookmark (I click links in emails sent to me from LinkedIn, or I access the site directly with the URL).

• After experiencing the problem, I upgraded to Firefox 52.9.0 -- The problem still persists.

• Cookies have been removed.

• History deleted using "Forget About This Site" (History > Show All History -- Right click on the site > Forget About This Site).

I got excited after using "Forget About This Site" because I was able to access LinkedIn.com. BUT... When I logged in, I got a blank screen with the Logo & a progress bar moving from side to side (see attachment). The site never loads.

Then, I tried accessing the site in a Private Window (right click on the link & select "Open Link in New Private Window"). I was able to access the site AND log in just fine. What The ****?!?! While excited that I can finally use Firefox to access the site, why do I need to use private browsing all of a sudden?

Attached screenshots

Modified by shannonphx

All Replies (4)

more options

HI, not sure but your in. Fixing the issue may get rid of your plugins you managed to update with. As things I would suggest would rip them out. Have to decide if 1 site is worth it.

more options

I'd rather not wipe out all plug ins, add ons & extensions. I did remove the unnecessary ones, which did not fix the issue. I just don't understand why – all of a sudden – I'm having this issue (before & after most recent update). I haven't added anything new at all. So frustrating!

more options

Please : Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

The problem still happens in Safe Mode.  :(