Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

More than 50 bookmarks makes firefox slow/hang

  • 2 replies
  • 1 has this problem
  • 2 views
  • Last reply by Pj

more options

Running on Windows 7 on high end hardware with high speed internet. (Multiple systems) I have had to keep the number of bookmarks to under 50 for the last year at least. What appears to happen is I add more than a magic(?) number of bookmarks and my system slows to a crawl and Firefox is basically hung. I tried restarting with all addin's removed. Does not work. I delete bookmarks (painfully) until under 50 and restart Firefox.... Full speed ahead. I have the bookmarks organized in 6 folders outside 'Other Bookmarks'. I have 8 bookmarks in 'Other Bookmarks' and 12 in 'bookmarks Toolbar' This has happened for over a year. Finally just got frustrated enough to report it.

All Replies (2)

more options

HI, please monitor in Windows Task Manager as to ram/cpu usage and report along with what the total amount of ram is please.

Please : Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

joe_admin said

Running on Windows 7 on high end hardware with high speed internet. (Multiple systems) I have had to keep the number of bookmarks to under 50 for the last year at least. What appears to happen is I add more than a magic(?) number of bookmarks and my system slows to a crawl and Firefox is basically hung. I tried restarting with all addons removed. Does not work. I delete bookmarks (painfully) until under 50 and restart Firefox.... Full speed ahead. I have the bookmarks organized in 6 folders outside 'Other Bookmarks'. I have 8 bookmarks in 'Other Bookmarks' and 12 in 'bookmarks Toolbar' This has happened for over a year. Finally just got frustrated enough to report it.

What's the update on your problem? I have 100's of Bookmarks. I have an old computer (Nov 2010) with Windows-7 Pro SP1 and 8GB of Memory with a RamBoost Drive and a 3GB Page File. I monitor my computer performance with Task Manager.