X
Tap here to go to the mobile version of the site.

Support Forum

Why does firefox keep highlighting English words as wrongly spelt?

Posted

I've installed the British English Dictionary and Language pack. They are confirmed as active in Add-on Manager. Using the latest version of Firefox at present. Version 61.0. Checking for updates from About finds no newer version.

Yet, still Firefox insists on trying to make everything American English. How can I stop it doing that?

Is the only way to completely remove it and start again from the beginning?

Windows 10.

I've installed the British English Dictionary and Language pack. They are confirmed as active in Add-on Manager. Using the latest version of Firefox at present. Version 61.0. Checking for updates from About finds no newer version. Yet, still Firefox insists on trying to make everything American English. How can I stop it doing that? Is the only way to completely remove it and start again from the beginning? Windows 10.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 30.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

More Information

FredMcD
  • Top 10 Contributor
4267 solutions 59838 answers

Is the American spell checker also installed?

Is the American spell checker also installed?

Question owner

FredMcD said

Is the American spell checker also installed?

Looking in Add-on Manager it shows English (GB) under Languages and British Dictionary under Dictionaries. I can't see anything that says American spellchecker anywhere.

So, I did a bit more digging and searched for "spellchecker" in about:config and found there is a setting called spellchecker.dictionary that was set to en-US. Changed that to en-GB.

Hopefully that will trigger the spellchecker to use the installed English (GB) language and dictionary.

Edit: Restarted Firefox and that has fixed it! Thanks for setting me on the right path. I thought it would be something obvious and not that hidden. Normally I don't like messing around with the internals of software. I hope others find this useful.

''FredMcD [[#answer-1127817|said]]'' <blockquote> Is the American spell checker also installed? </blockquote> Looking in Add-on Manager it shows English (GB) under Languages and British Dictionary under Dictionaries. I can't see anything that says American spellchecker anywhere. So, I did a bit more digging and searched for "spellchecker" in about:config and found there is a setting called spellchecker.dictionary that was set to en-US. Changed that to en-GB. Hopefully that will trigger the spellchecker to use the installed English (GB) language and dictionary. '''Edit:''' Restarted Firefox and that has fixed it! Thanks for setting me on the right path. I thought it would be something obvious and not that hidden. Normally I don't like messing around with the internals of software. I hope others find this useful.

Modified by alowe

James
  • Top 25 Contributor
  • Moderator
1600 solutions 11319 answers

https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker

You can have multiple dictionaries installed. The issue is you need to select which one you want the inline spellchecker to use at the time.

https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker#w_switching-dictionaries

https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker You can have multiple dictionaries installed. The issue is you need to select which one you want the inline spellchecker to use at the time. https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker#w_switching-dictionaries