X
Tap here to go to the mobile version of the site.

Support Forum

Mozilla recently installed a new update on my pc, and since then I can't access Google search properly or Gmail at all.

Posted

A couple of days ago, Mozilla updated my Firefox browser on my Windows laptop. While the rest of it works fine and I'm still cookied in to everything, I can no longer access my Gmail account - I get a response saying 'secure connection failed' with the following error code: SSL_ERROR_RX_RECORD_TOO_LONG. I also can't use the Google search function when I open a new browser window, although it does seem to work when I go to the Google homepage.

Any suggestions?

A couple of days ago, Mozilla updated my Firefox browser on my Windows laptop. While the rest of it works fine and I'm still cookied in to everything, I can no longer access my Gmail account - I get a response saying 'secure connection failed' with the following error code: SSL_ERROR_RX_RECORD_TOO_LONG. I also can't use the Google search function when I open a new browser window, although it does seem to work when I go to the Google homepage. Any suggestions?

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5279 solutions 23327 answers

hi, thanks for reporting the problem, so far we have heard about this from avast/avg users whose security software is meddling with encrypted connections. firefox 61 introduced the better security protocol tls 1.3 & apparently avast can't cope with that yet.

as a workaround, please try to disable the scanning of https connections as described in https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message#w_avast-and-avg-security-products

hi, thanks for reporting the problem, so far we have heard about this from avast/avg users whose security software is meddling with encrypted connections. firefox 61 introduced the better security protocol tls 1.3 & apparently avast can't cope with that yet. as a workaround, please try to disable the scanning of https connections as described in https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message#w_avast-and-avg-security-products