X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

When I set my privacy to never remember history it switches back to custom, why?

Posted

This occurred after my last update and I definitely do not want it doing that. What's the solution?

This occurred after my last update and I definitely do not want it doing that. What's the solution?

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Logitech Harmony Remote Plugin
  • Shockwave Flash 22.0 r0
  • 5.1.50428.0
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

jscher2000
  • Top 10 Contributor
8950 solutions 73362 answers

Firefox will show the custom settings for history section if you have made any customizations that differ from one of the other settings.

"Never remember history" is the same as "Always use private browsing mode", so if that box is checked, you're covered.

Perhaps you also modified cookie settings or one of the other settings in this section?

Firefox will show the custom settings for history section if you have made any customizations that differ from one of the other settings. "Never remember history" is the same as "Always use private browsing mode", so if that box is checked, you're covered. Perhaps you also modified cookie settings or one of the other settings in this section?