Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

accessing my email address

  • 6 replies
  • 1 has this problem
  • 74 views
  • Last reply by AliceWyman

more options

I seem to have done something to limit access to my Emails. I answered a request from Fox to click on security and now I am locked out!! How do I undo this?

Chosen solution

An update to Firefox was just released which can cause the problem. This is from the Firefox 61 release notes:


Users with Avast or AVG security software using the HTTPS Scanning feature may get an error message (SSL_ERROR_RX_RECORD_TOO_LONG) when trying to access secure sites. Workarounds are available from this support article until fixed versions of Avast and AVG are available.


The support article link goes to a section of the Secure connection failed and Firefox did not connect article, which explains how to turn off HTTPS scanning in the Web Shield component of Avast/AVG. For more information, see Managing HTTPS scanning in Web Shield in Avast Antivirus on the Avast support site.

Read this answer in context 👍 0

All Replies (6)

more options

Please explain the problem in detail. What happens? Error messages?

more options

FredMcD said

Please explain the problem in detail. What happens? Error messages?

Cannot access my gmail via google through firefox. Error code :- SSL_ERROR_RX_RECORD_TOO_LONG

more options

Wantirna said

FredMcD said
Please explain the problem in detail. What happens? Error messages?

Cannot access my gmail via google through firefox. Error code :- SSL_ERROR_RX_RECORD_TOO_LONG

more options

cannot access my gmail .Error code :- SSL_ERROR_RX+RECORD_TOO_LONG

more options

Please don't repeat your messages. It wastes room.


There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connections and send their own certificate.

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

http://kb.mozillazine.org/Error_loading_websites


‘ssl_error_rx_record_too_long’ or ‘cannot display the webpage’ Internet search; More often than not, you have something misconfigured!

more options

Chosen Solution

An update to Firefox was just released which can cause the problem. This is from the Firefox 61 release notes:


Users with Avast or AVG security software using the HTTPS Scanning feature may get an error message (SSL_ERROR_RX_RECORD_TOO_LONG) when trying to access secure sites. Workarounds are available from this support article until fixed versions of Avast and AVG are available.


The support article link goes to a section of the Secure connection failed and Firefox did not connect article, which explains how to turn off HTTPS scanning in the Web Shield component of Avast/AVG. For more information, see Managing HTTPS scanning in Web Shield in Avast Antivirus on the Avast support site.