Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Since latest Firefox update, google.com gives error "Secure Connection Failed An error occurred during a connection to www.google.com. SSL received a record th

  • 7 replies
  • 3 have this problem
  • 308 views
  • Last reply by Shadow110

more options

Since the most recent Firefox update to 61.0 on windows 7 64 bit computer, google.com fails to come in, giving this message:

Secure Connection Failed

An error occurred during a connection to www.google.com. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.

All Replies (7)

more options

If you have a vast antivirus disable web shield and see if problem persists if it doesnt then it's the same thing I been facing all day until a fix downgrade back to 60.02 that's what I had to do

Modified by Muldercs

more options

Thanks for the suggestion, but I have AVG, and disabling web shield or downgrading are security risks. Since no other websites have shown the problem yet, I'll wait for the next upgrade fix. Yahoo.com has been working fine as an alternate search engine.

more options

HI, Avast bought out AVG

There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connections and send their own certificate.

If you have any of the above which you do please head to the AVG Forum for info on how to run it with Firefox as it is a matter of some options.

Please let us know if this solved your issue or if need further assistance.

more options

In recent days:

"SSL_ERROR_RX_RECORD_TOO_LONG" occurs when Firefox and a website try to negotiate a connection using the latest TLS protocol (version 1.3) and the man-in-the-middle (Avast Web Shield or AVG Web Shield) somehow messes it up.

Until this is sorted out, I think your two workarounds are:

(1) Remove the man in the middle (disable Web Shield for secure connections).

See the Avast section of: How to troubleshoot security error codes on secure websites.

(2) Disable TLS 1.3 in Firefox so it connects using an older protocol. To do that:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(B) In the search box above the list, type or paste TLS and pause while the list is filtered

(C) Double-click the security.tls.version.max preference to display a dialog where you can change the value from 4 to 3 (this corresponds to TLS 1.2) and then click OK

more options

Thanks jscher2000 Using your number 2 option worked also!

more options

Your suggestion lead me to a solution:

Open AVG, Menu, Settings, Components, on Webshield choose Customize, Exceptions where I then added https://www.google.com. Now it comes in without problem as homepage and bookmark.

Thanks.

Modified by NoahSUMO

more options

HI, glad your all fixed up. This just turned up now. Please see if this was the correct time you updated your reply as if it is not your a day off.