X
Tap here to go to the mobile version of the site.

Support Forum

FF V61 is blocking a known safe site.

Posted

Last night I let FF update to V61 on my laptop. Now I can't access https://800notes.com/. I use the site to check on the multitude of bogus phone calls I get on my home phone every day. When trying to access the site I get a message about some string of something being too long. My desktop (which I'm now on and still using V60.0.2 accesses the site just fine). I've been on 800 notes thousands of times and know for a fact it's a safe site. When FF blocks me I don't get an option to whilelist it or bypass the block. IE goes straight to the site with no problems. I'm 70 and not a geek so the cryptic messages FF gives me might as well be greek for all the good they do in providing information I can use. Is this something I can fix?

Last night I let FF update to V61 on my laptop. Now I can't access https://800notes.com/. I use the site to check on the multitude of bogus phone calls I get on my home phone every day. When trying to access the site I get a message about some string of something being too long. My desktop (which I'm now on and still using V60.0.2 accesses the site just fine). I've been on 800 notes thousands of times and know for a fact it's a safe site. When FF blocks me I don't get an option to whilelist it or bypass the block. IE goes straight to the site with no problems. I'm 70 and not a geek so the cryptic messages FF gives me might as well be greek for all the good they do in providing information I can use. Is this something I can fix?

Chosen solution

avg is meddling with secure connections - apparently they're not correctly dealing with the more secure tls1.3 standard that's enabled in firefox 61 by default. please disable the scanning of https connection within the avg webshield like described here for avast (they are the same company): https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER#w_avast

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 30.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:60.0) Gecko/20100101 Firefox/60.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5282 solutions 23337 answers

hi, are you a user of avast/avg security software?

hi, are you a user of avast/avg security software?

Question owner

The laptop has AVG. AVG has never blocked the site before. I accessed it on the laptop earlier in the day before the update to V61. The message I get is from FF not AVG. AVG isn't the software blocking the site. It's something like "Fire Fox has detected............."

The laptop has AVG. AVG has never blocked the site before. I accessed it on the laptop earlier in the day before the update to V61. The message I get is from FF not AVG. AVG isn't the software blocking the site. It's something like "Fire Fox has detected............."

Modified by TinyThomas

philipp
  • Top 25 Contributor
  • Moderator
5282 solutions 23337 answers

Chosen Solution

avg is meddling with secure connections - apparently they're not correctly dealing with the more secure tls1.3 standard that's enabled in firefox 61 by default. please disable the scanning of https connection within the avg webshield like described here for avast (they are the same company): https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER#w_avast

avg is meddling with secure connections - apparently they're not correctly dealing with the more secure tls1.3 standard that's enabled in firefox 61 by default. please disable the scanning of https connection within the avg webshield like described here for avast (they are the same company): https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER#w_avast

Question owner

I just edited my answer above. The message I get is a FF message. Not AVG. Give me a minute and I'll get on my laptop and get a more accurate quote of the message.

I just edited my answer above. The message I get is a FF message. Not AVG. Give me a minute and I'll get on my laptop and get a more accurate quote of the message.

Modified by TinyThomas

Tyler Downer
  • Top 25 Contributor
  • Moderator
1525 solutions 10623 answers

Yes, the message is from Firefox, but AVG is messing with the secure connection, breaking Firefox and causing this issue.

Honestly, AVG is not a good anti-virus anyway (This sort of man in the middle attack is not a good practice) so i suggest just uninstalling it and using Windows Defender.

Yes, the message is from Firefox, but AVG is messing with the secure connection, breaking Firefox and causing this issue. Honestly, AVG is not a good anti-virus anyway (This sort of man in the middle attack is not a good practice) so i suggest just uninstalling it and using Windows Defender.

Question owner

Attached is a screenshot of the message.

Attached is a screenshot of the message.

Question owner

I don't think Windows Defender is on Win7 is it? Is it something I can download?

I don't think Windows Defender is on Win7 is it? Is it something I can download?
philipp
  • Top 25 Contributor
  • Moderator
5282 solutions 23337 answers

that's called microsoft security essentials on windows 7 - besides that, have you seen my prior reply about the config change in avg that's known to fix this problem?

that's called microsoft security essentials on windows 7 - besides that, have you seen my prior reply about the config change in avg that's known to fix this problem?
jscher2000
  • Top 10 Contributor
8591 solutions 70247 answers

Yes "SSL_ERROR_RX_RECORD_TOO_LONG" occurs when Firefox and a website try to negotiate a connection using the latest TLS protocol (version 1.3) and the man-in-the-middle (Avast or AVG Web Shield) somehow messes it up.

As of now, I think your two workarounds are:

(1) Remove the man in the middle (disable Web Shield for secure connections)

(2) Disable TLS 1.3 in Firefox so the connection uses an older protocol

Yes "SSL_ERROR_RX_RECORD_TOO_LONG" occurs when Firefox and a website try to negotiate a connection using the latest TLS protocol (version 1.3) and the man-in-the-middle (Avast or AVG Web Shield) somehow messes it up. As of now, I think your two workarounds are: (1) Remove the man in the middle (disable Web Shield for secure connections) (2) Disable TLS 1.3 in Firefox so the connection uses an older protocol

Modified by jscher2000

Tyler Downer
  • Top 25 Contributor
  • Moderator
1525 solutions 10623 answers

It is, it's simply disabled because you have AVG. Uninstall AVG, and it should be enabled. You can verify it easily.

It is, it's simply disabled because you have AVG. Uninstall AVG, and it should be enabled. You can verify it easily.

Question owner

philipp said

that's called microsoft security essentials on windows 7 - besides that, have you seen my prior reply about the config change in avg that's known to fix this problem?

I will try that. It'll take a few minutes to get to the laptop and try to do the procedure you recommend.

''philipp [[#answer-1126803|said]]'' <blockquote> that's called microsoft security essentials on windows 7 - besides that, have you seen my prior reply about the config change in avg that's known to fix this problem? </blockquote> I will try that. It'll take a few minutes to get to the laptop and try to do the procedure you recommend.

Question owner

By golly, that worked! Thank you. I have Norton on my desktop. Will I run into the same thing on my desktop if I let FF update to V61?

By golly, that worked! Thank you. I have Norton on my desktop. Will I run into the same thing on my desktop if I let FF update to V61?
Tyler Downer
  • Top 25 Contributor
  • Moderator
1525 solutions 10623 answers

Norton hasn't been reported yet, but they do shady things as well. I suggest removing all anti-virus and just using Windows Defender

Norton hasn't been reported yet, but they do shady things as well. I suggest removing all anti-virus and just using Windows Defender

Question owner

Thanks to all for the help. This old man appreciates it. If the same thing happens on my desktop at least I have an inkling of what's going on. Thanks again.

Thanks to all for the help. This old man appreciates it. If the same thing happens on my desktop at least I have an inkling of what's going on. Thanks again.
Tyler Downer
  • Top 25 Contributor
  • Moderator
1525 solutions 10623 answers

I should note, this is what happened in this situation:

In Firefox 61, we released a new version of the protocol used for secure websites (TLS 1.3). Because AVG and Avast are doing shady things to your internet connection, they broke things. It is best to either uninstall those anti-virus, of disable the "features" that are basically hijacking your internet connection for the anti-virus can do whatever the hell they want to your internet.

For Windows, Windows Defender is a great anti-virus that is light-weight and far more capable than these shady antivirus

I should note, this is what happened in this situation: In Firefox 61, we released a new version of the protocol used for secure websites (TLS 1.3). Because AVG and Avast are doing shady things to your internet connection, they broke things. It is best to either uninstall those anti-virus, of disable the "features" that are basically hijacking your internet connection for the anti-virus can do whatever the hell they want to your internet. For Windows, Windows Defender is a great anti-virus that is light-weight and far more capable than these shady antivirus