Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

videos will not load

  • 7 replies
  • 1 has this problem
  • 3 views
  • Last reply by FredMcD

more options

https://www.yahoo.com/entertainment/rose-leslie-married-kit-harington-194155767.html

Above is an example of videos not loading in Firefox. Happens all the time on many many web sites. Just spins in a loop and never loads. Site work perfect in Safari so it is a Firefox issue.

I have used Firefox for years, but may have to trash it off my computers. It has become unpredictable, and buggy.

Did all the stuff suggested makes no difference. You never know what to expect with this browser.

Chosen solution

rlmrlm said

I rebuilt and reinstalled Firefox, and the video now works

It could have been a corrupt file that was overwritten.

That was very good work. Well done. Please flag your last post as Solved Problem so others will know. +++++++++++++++++++++++++++++++++++++++ WestEnd said

The problem is if it failed to load in Safe Mode that would indicate Browser install problem

Not necessarily. It could be something on the computer is causing the issue.

Read this answer in context 👍 0

All Replies (7)

more options

I had no problem with the link.

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

more options

Video did not play in safe mode. At least it appeared but would not play.

When selected skip add opened other tabs with advertising no video play.

it is a Yahoo. protected video

Check tracking protection sent to basic.

more options

The problem is if it failed to load in Safe Mode that would indicate Browser install problem. How did you install FF?

more options

Been installed since iMac was put into use several year ago. Standard updates over time with Firefox update loads. Nothing unusual.

more options

Activity Monitor

more options

I rebuilt and reinstalled Firefox, and the video now works. Have no idea why I had to do that. However, thank you for responding.

more options

Chosen Solution

rlmrlm said

I rebuilt and reinstalled Firefox, and the video now works

It could have been a corrupt file that was overwritten.

That was very good work. Well done. Please flag your last post as Solved Problem so others will know. +++++++++++++++++++++++++++++++++++++++ WestEnd said

The problem is if it failed to load in Safe Mode that would indicate Browser install problem

Not necessarily. It could be something on the computer is causing the issue.