X
Tap here to go to the mobile version of the site.

Support Forum

Firefox doesn't open tab in background with CMD

Posted

I know there is https://support.mozilla.org/en-US/questions/1071788 and https://support.mozilla.org/en-US/questions/1061460 but suggested `browser.tabs.loadDivertedInBackground` doesn't work for me - it simply opens everything in the background which is even more annoying.

At this point I would consider this a bug - I don't give a rat's nose about what magic javascript (pseudo-)developers but if I hold CMD button and make a click I want window to be opened in the background! (it seems that gmail is the main culprit, but probably most of google-produced FantasticCreation is affected by it…)

I know there is https://support.mozilla.org/en-US/questions/1071788 and https://support.mozilla.org/en-US/questions/1061460 but suggested `browser.tabs.loadDivertedInBackground` doesn't work for me - it simply opens everything in the background which is even more annoying. At this point I would consider this a bug - I don't give a rat's nose about what magic javascript (pseudo-)developers but if I hold CMD button and make a click I want window to be opened in the background! (it seems that gmail is the main culprit, but probably most of google-produced FantasticCreation is affected by it…)

Chosen solution

I've tested this on Gmail, and I can confirm your issue, so I did some searching in Mozilla's public bug database. There is one filed 5 months ago, and it was determined to be a Google issue. They reached out to Google, who responded that "Our QA team can reproduce, we're tracking this internally..."

For now, middle-click or control-click > Open Link in New Tab should still work.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 28.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:60.0) Gecko/20100101 Firefox/60.0

More Information

Shadow110 1072 solutions 14836 answers

Separate Security Issue, please update your Flash 28.0 r0 https://get.adobe.com/flashplayer/ Current Version 30.0.0.113

Hi, Since extension information did not turn up please : Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Separate Security Issue, please update your Flash 28.0 r0 https://get.adobe.com/flashplayer/ Current Version 30.0.0.113 Hi, Since extension information did not turn up please : '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Question owner

Can we ban those "top 10 contributors" which only spams forums with COMPLETELY UNRELATED responses?

NO! Safe mode doesn't solve the issue nor updating flash… *sigh*

Can we ban those "top 10 contributors" which only spams forums with '''COMPLETELY UNRELATED''' responses? NO! Safe mode doesn't solve the issue nor updating flash… *sigh*
Chris Ilias
  • Moderator
353 solutions 1941 answers

Hi wojtek, The purpose of safe mode is to find out if you have any add-ons that may be causing your command key not to work. It's a troubleshooting tool.

I'm also on macOS, so I can help you. :)

First, let's verify your settings. If you go to Firefox > Preferences > General, then scroll to the Tabs section make sure When I open a link in a new tab, switch to it immediately is disabled. For more information, see Startup, home page, tabs, and download settings

If the problem still occurs, we'll need some more info about your Firefox setup. Go to [=] > Help > Troubleshooting Information then click Copy text to Clipboard. Open a reply to this post, and go to Edit > Paste to paste the info from your Troubleshooting Information page.

Hi wojtek, The purpose of safe mode is to find out if you have any add-ons that may be causing your command key not to work. It's a troubleshooting tool. I'm also on macOS, so I can help you. :) First, let's verify your settings. If you go to '''Firefox > Preferences > General''', then scroll to the ''Tabs'' section make sure '''When I open a link in a new tab, switch to it immediately''' is disabled. For more information, see [[Startup, home page, tabs, and download settings]] If the problem still occurs, we'll need some more info about your Firefox setup. Go to '''[=] > Help > Troubleshooting Information''' then click '''Copy text to Clipboard'''. Open a reply to this post, and go to '''Edit > Paste''' to paste the info from your Troubleshooting Information page.
cor-el
  • Top 10 Contributor
  • Moderator
17421 solutions 157403 answers

There is a setting to open links in tabs in the background, but there is no such setting for opening a links in a new window as far as I know. loadDivertedInBackground is about links opened via JavaScript.

You can hold the Shift key in addition of the Command key (Shift+Command and left-click) to toggle the background/focus setting as set in Options/Preferences.

There is a setting to open links in tabs in the background, but there is no such setting for opening a links in a new window as far as I know. loadDivertedInBackground is about links opened via JavaScript. You can hold the Shift key in addition of the Command key (Shift+Command and left-click) to toggle the background/focus setting as set in Options/Preferences.

Question owner

Chris Ilias said

Hi wojtek, The purpose of safe mode is to find out if you have any add-ons that may be causing your command key not to work. It's a troubleshooting tool. I'm also on macOS, so I can help you. :) First, let's verify your settings. If you go to Firefox > Preferences > General, then scroll to the Tabs section make sure When I open a link in a new tab, switch to it immediately is disabled. For more information, see Startup, home page, tabs, and download settings If the problem still occurs, we'll need some more info about your Firefox setup. Go to [=] > Help > Troubleshooting Information then click Copy text to Clipboard. Open a reply to this post, and go to Edit > Paste to paste the info from your Troubleshooting Information page.

I know the purpose of safe mode, and most of the time I use it before posting - and I did it this time as well :-)

cor-el said

There is a setting to open links in tabs in the background, but there is no such setting for opening a links in a new window as far as I know. loadDivertedInBackground is about links opened via JavaScript. You can hold the Shift key in addition of the Command key (Shift+Command and left-click) to toggle the background/focus setting as set in Options/Preferences.

I have this option de-selected.

But the problem is not that Firefox always fail to open in background - it only fails on some sites (as mentioned in the original post - gmail is one of the examples). There is probably some JS mambo-jumbo at play which overrides original firefox setting. Again - I tried browser.tabs.loadDivertedInBackground but then it open everything in background tab which is less then ideal…

''Chris Ilias [[#answer-1123714|said]]'' <blockquote> Hi wojtek, The purpose of safe mode is to find out if you have any add-ons that may be causing your command key not to work. It's a troubleshooting tool. I'm also on macOS, so I can help you. :) First, let's verify your settings. If you go to '''Firefox > Preferences > General''', then scroll to the ''Tabs'' section make sure '''When I open a link in a new tab, switch to it immediately''' is disabled. For more information, see [[Startup, home page, tabs, and download settings]] If the problem still occurs, we'll need some more info about your Firefox setup. Go to '''[=] > Help > Troubleshooting Information''' then click '''Copy text to Clipboard'''. Open a reply to this post, and go to '''Edit > Paste''' to paste the info from your Troubleshooting Information page. </blockquote> I know the purpose of safe mode, and most of the time I use it before posting - and I did it this time as well :-) ''cor-el [[#answer-1123784|said]]'' <blockquote> There is a setting to open links in tabs in the background, but there is no such setting for opening a links in a new window as far as I know. loadDivertedInBackground is about links opened via JavaScript. You can hold the Shift key in addition of the Command key (Shift+Command and left-click) to toggle the background/focus setting as set in Options/Preferences. </blockquote> I have this option de-selected. But the problem is not that Firefox always fail to open in background - it only fails on some sites (as mentioned in the original post - '''gmail''' is one of the examples). There is probably some JS mambo-jumbo at play which overrides original firefox setting. Again - I tried '''browser.tabs.loadDivertedInBackground''' but then it open everything in background tab which is less then ideal…
Chris Ilias
  • Moderator
353 solutions 1941 answers

Chosen Solution

I've tested this on Gmail, and I can confirm your issue, so I did some searching in Mozilla's public bug database. There is one filed 5 months ago, and it was determined to be a Google issue. They reached out to Google, who responded that "Our QA team can reproduce, we're tracking this internally..."

For now, middle-click or control-click > Open Link in New Tab should still work.

I've tested this on Gmail, and I can confirm your issue, so I did some searching in Mozilla's public bug database. There is one filed 5 months ago, and it was determined to be a Google issue. They reached out to Google, who responded that "''Our QA team can reproduce, we're tracking this internally...''" For now, '''middle-click''' or '''control-click > Open Link in New Tab''' should still work.

Question owner

OK, I don't have middle-click on touchpad and context-menu is a bit inconvenient.

Could you share the bug you've found?

On the separate note - how this could be gmail/google bug? How on earth a website could override user setting?

OK, I don't have middle-click on touchpad and context-menu is a bit inconvenient. Could you share the bug you've found? On the separate note - how this could be gmail/google bug? How on earth a website could override user setting?
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

.wojtek said

On the separate note - how this could be gmail/google bug? How on earth a website could override user setting?

The message list in the Gmail inbox -- at least the one I see -- doesn't use links at all. It is a heavily scripted table. The regular behaviors for links are not applicable in that case; Google does whatever it wants to.

''.wojtek [[#answer-1123892|said]]'' <blockquote> On the separate note - how this could be gmail/google bug? How on earth a website could override user setting? </blockquote> The message list in the Gmail inbox -- at least the one I see -- doesn't use links at all. It is a heavily scripted table. The regular behaviors for links are not applicable in that case; Google does whatever it wants to.

Question owner

jscher2000 said

The message list in the Gmail inbox -- at least the one I see -- doesn't use links at all. It is a heavily scripted table. The regular behaviors for links are not applicable in that case; Google does whatever it wants to.

But problem is not the message list but any link within a message. I opened dev console and it looks like a normal link:

<a href="…" style="box-sizing:border-box;color:#4477bd;font-family:'Helvetica Neue','Helvetica',Helvetica,Arial,sans-serif;font-size:20px;font-weight:bold;line-height:1.5;text-decoration:underline" target="_blank" data-saferedirecturl="…">blablabla</a>

I thought that it was cause by target="_blank" but removing it doesn't help.

I also found two somewhat related options: http://kb.mozillazine.org/Browser.link.open_newwindow http://kb.mozillazine.org/Browser.link.open_newwindow.restriction

But now matter how I would set them the link either always open in new focused tab or in the current window…

I would really love for the web to go back to simplest form…

''jscher2000 [[#answer-1123899|said]]'' <blockquote> The message list in the Gmail inbox -- at least the one I see -- doesn't use links at all. It is a heavily scripted table. The regular behaviors for links are not applicable in that case; Google does whatever it wants to. </blockquote> But problem is not the message list but any link within a message. I opened dev console and it looks like a normal link: ''' <a href="…" style="box-sizing:border-box;color:#4477bd;font-family:'Helvetica Neue','Helvetica',Helvetica,Arial,sans-serif;font-size:20px;font-weight:bold;line-height:1.5;text-decoration:underline" target="_blank" data-saferedirecturl="…">blablabla</a> ''' I thought that it was cause by target="_blank" but removing it doesn't help. I also found two somewhat related options: http://kb.mozillazine.org/Browser.link.open_newwindow http://kb.mozillazine.org/Browser.link.open_newwindow.restriction But now matter how I would set them the link either always open in new focused tab or in the current window… I would really love for the web to go back to simplest form…
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

.wojtek said

But problem is not the message list but any link within a message.

As far as I can tell, I have just the default settings and when I Ctrl+click an ordinary link in a message (on Windows), it opens in a new tab in the background. These happen to be messages from various Google services; I'm not using this particular mailbox for anything exciting. I can't test on Mac at the moment.

''.wojtek [[#answer-1123915|said]]'' <blockquote> But problem is not the message list but any link within a message. </blockquote> As far as I can tell, I have just the default settings and when I Ctrl+click an ordinary link in a message (on Windows), it opens in a new tab in the background. ''These happen to be messages from various Google services; I'm not using this particular mailbox for anything exciting.'' I can't test on Mac at the moment.
Chris Ilias
  • Moderator
353 solutions 1941 answers

Helpful Reply

.wojtek said

OK, I don't have middle-click on touchpad and context-menu is a bit inconvenient. Could you share the bug you've found?

Here you go: https://bugzilla.mozilla.org/show_bug.cgi?id=1429831 NOTE: Bugzilla is not for feedback or support. For more info on Bugzilla etiquette, see https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

''.wojtek [[#answer-1123892|said]]'' <blockquote> OK, I don't have middle-click on touchpad and context-menu is a bit inconvenient. Could you share the bug you've found? </blockquote> Here you go: https://bugzilla.mozilla.org/show_bug.cgi?id=1429831 '''NOTE:''' Bugzilla is not for feedback or support. For more info on Bugzilla etiquette, see https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

Question owner

Chris Ilias said

.wojtek said
OK, I don't have middle-click on touchpad and context-menu is a bit inconvenient. Could you share the bug you've found?

Here you go: https://bugzilla.mozilla.org/show_bug.cgi?id=1429831 NOTE: Bugzilla is not for feedback or support. For more info on Bugzilla etiquette, see https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

Thanks - this is exactly the problem. I followed the bug but... this shows how broken/quirky the web is :(

''Chris Ilias [[#answer-1123949|said]]'' <blockquote> ''.wojtek [[#answer-1123892|said]]'' <blockquote> OK, I don't have middle-click on touchpad and context-menu is a bit inconvenient. Could you share the bug you've found? </blockquote> Here you go: https://bugzilla.mozilla.org/show_bug.cgi?id=1429831 '''NOTE:''' Bugzilla is not for feedback or support. For more info on Bugzilla etiquette, see https://bugzilla.mozilla.org/page.cgi?id=etiquette.html </blockquote> Thanks - this is exactly the problem. I followed the bug but... this shows how broken/quirky the web is :(