Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Quantum 60.0.2 updated June 7, 2018 and now my Yahoo mail is incredibly slow. How do I fix this?

  • 1 reply
  • 1 has this problem
  • 5 views
  • Last reply by FredMcD

more options

On June 7, 2018, Firefox Quantum updated automatically to 60.0.2 on my MacBookPro running macOS Sierra 10.12.6. Firefox is my default Browser and it is set to open on my homepage: uk.yahoo.com/. My Yahoo mail is now incredibly slow and I cannot refresh the page without a 30 second delay, if it works at all. In my Yahoo Mail, I cannot open any new emails quickly, I cannot move to spam quickly and I cannot go to trash quickly to empty it. It opens my Homepage, Google Search, Bookmarks and other websites quickly. However, while I am in my Yahoo Mail there are huge delays and freezes. Moving through my Yahoo Mail is slower that it has ever been. It seems to be operating at old dial up speeds. It is not delaying movement between emails or using the move to function by a few seconds but rather 30 seconds on average. It is painfully slow. I do not know if this is relevant but upon opening the URL box displays a green lock but after opening any email it changes to a black lock with a yellow triangle everytime. If it allows me to refresh, the lock goes back to Green. Several months ago, I changed from Yahoo Classic Mail to New Yahoo Mail. I am not using Yahoo Mail Pro that charges a fee for use. I do not know what to do. Last week when using FF quantum 60.0.1 I could not open any attachments. I still cannot open most attachments. It now seems to be hit or miss. I do not know if this is related to the Mail Slowness problem. Please advise? Many thanks.

All Replies (1)

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}