X
Tap here to go to the mobile version of the site.

Support Forum

How do I enable the built-in pdf viewer and stop Firefox from using Acrobat Reader?

Posted

I have changed it to open in preview in preferences, but it still tries to download

I have changed it to open in preview in preferences, but it still tries to download

Chosen solution

I tried a few public sights and it seems to be working. The one I am having issue with is secure, so I will try to contact them directly. It must be an issue on their end.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 30.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:60.0) Gecko/20100101 Firefox/60.0

More Information

TyDraniu
  • Top 25 Contributor
319 solutions 1831 answers

chadfarneti said

I have changed it to open in preview in preferences, but it still tries to download

But after downloading is the file opening in the Adobe Reader?

''chadfarneti [[#question-1221428|said]]'' <blockquote> I have changed it to open in preview in preferences, but it still tries to download </blockquote> But after downloading is the file opening in the Adobe Reader?

Question owner

Yes. I I try to preview in firefox but it takes me to the download popup

Yes. I I try to preview in firefox but it takes me to the download popup
TyDraniu
  • Top 25 Contributor
319 solutions 1831 answers

It depends of the content-type header. If server says that browser must download the file, it will be downloaded, regardless of your setup.

It depends of the content-type header. If server says that browser must download the file, it will be downloaded, regardless of your setup.

Question owner

This just started happening today. It has worked flawlessly for the past 2 years...

This just started happening today. It has worked flawlessly for the past 2 years...
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Is the problem only on one particular site or does it affect ALL PDF files from all sources?

Have you shut down your Mac and restarted it since this problem began?

Is the problem only on one particular site or does it affect ALL PDF files from all sources? Have you shut down your Mac and restarted it since this problem began?

Question owner

I had an update to install, restarted and the problem still exists.

I had an update to install, restarted and the problem still exists.
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

If Firefox stops obeying the Application settings listed on the Options page, you may need to remove a settings file and have Firefox regenerate it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default, double-click it to display the contents of that profile folder.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit/Quit
  • (menu bar) File > Exit (or Firefox > Quit)

Pause while Firefox finishes its cleanup, then:

  • rename handlers.json to something like handlersOLD.json
  • if you see a file named mimeTypes.rdf, rename that one to mimeTypesOLD.rdf

Start Firefox back up again and it should revert to the default download handling settings, in this case, "Preview in Firefox" for PDFs. Any improvement?

If Firefox stops obeying the Application settings listed on the Options page, you may need to remove a settings file and have Firefox regenerate it. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter/Return In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default, double-click it to display the contents of that profile folder. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > Exit/Quit * (menu bar) File > Exit (or Firefox > Quit) Pause while Firefox finishes its cleanup, then: * rename '''handlers.json''' to something like '''handlersOLD.json''' * if you see a file named '''mimeTypes.rdf''', rename that one to '''mimeTypesOLD.rdf''' Start Firefox back up again and it should revert to the default download handling settings, in this case, "Preview in Firefox" for PDFs. Any improvement?
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

I just re-read your original post:

  • Open in Preview => should load in Apple's Preview app, if the server sent the document with the content-type "application/pdf"
  • Preview in Firefox => should load in the built-in viewer, if the server sent the document with the content-type "application/pdf"
I just re-read your original post: * Open in Preview => should load in Apple's Preview app, if the server sent the document with the content-type "application/pdf" * Preview in Firefox => should load in the built-in viewer, if the server sent the document with the content-type "application/pdf"

Question owner

Perhaps I am not explaining it correctly. I want the pdf to open in a webpage, not download and save to my downloads folder. I click a link to a pdf in a website and instead of opening in firefox, it opens a box to download the file. If I click open from a different application and select firefox, it opens in a new window and still saves to my downloads folder.

Perhaps I am not explaining it correctly. I want the pdf to open in a webpage, not download and save to my downloads folder. I click a link to a pdf in a website and instead of opening in firefox, it opens a box to download the file. If I click open from a different application and select firefox, it opens in a new window and still saves to my downloads folder.
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

So on the Preferences page you have Firefox set to

Portable Document Format (PDF) => "Preview in Firefox"

If Firefox doesn't follow that instruction, there are three typical explanations:

  • the server did not identify the file properly (the content-type is not specifically "application/pdf")
  • the server instructed Firefox to force a download (the content-disposition was set to attachment)
  • the handlers.json / mimeTypes.rdf file is corrupted with nonsense entries
So on the Preferences page you have Firefox set to Portable Document Format (PDF) => "Preview in Firefox" If Firefox doesn't follow that instruction, there are three typical explanations: * the server did not identify the file properly (the content-type is not specifically "application/pdf") * the server instructed Firefox to force a download (the content-disposition was set to attachment) * the handlers.json / mimeTypes.rdf file is corrupted with nonsense entries

Modified by jscher2000

Question owner

Does his look correct?

Does his look correct?
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Mine has action 3 as well, so that looks correct to me.

If Firefox shows a blank tab for the PDF and then immediately shows a Save dialog (bypassing the usual Open / Save / Cancel dialog), could you check this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste pdfjs and pause while the list is filtered

(3) If the pdfjs.disabled preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false

Mine has action 3 as well, so that looks correct to me. If Firefox shows a blank tab for the PDF and then immediately shows a Save dialog (bypassing the usual Open / Save / Cancel dialog), could you check this setting: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''pdfjs''' and pause while the list is filtered (3) If the '''pdfjs.disabled''' preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false

Question owner

it was set to default. still not working. thanks for all your help. if you want to give up, i understand.

it was set to default. still not working. thanks for all your help. if you want to give up, i understand.
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Is the problem with all PDFs or are only certain servers affected? For example, this old one definitely should open in a tab:

Firefox Search Bar Show Engine Names (Firefox 43+) | Userstyles.org - Firefox Search Bar Show Engine Names (Firefox 43) _20171004.pdf

Is the problem with all PDFs or are only certain servers affected? For example, this old one definitely should open in a tab: [https://www.jeffersonscher.com/temp/Firefox%20Search%20Bar%20Show%20Engine%20Names%20(Firefox%2043)%20_20171004.pdf Firefox Search Bar Show Engine Names (Firefox 43+) | Userstyles.org - Firefox Search Bar Show Engine Names (Firefox 43) _20171004.pdf]

Question owner

Those opened in a tab. I will contact the affected servers to see if there is an issue on their end. I really appreciate all your effort.

Those opened in a tab. I will contact the affected servers to see if there is an issue on their end. I really appreciate all your effort.
user1504726 2 solutions 48 answers

There is a totally simple explanation to this. I read an article on the Mozilla Support Page and it says that Firefox Quantum will no longer be supporting NPAPI plugins like Adobe Flash, Shockwave Flash, and Silverlight, because there are more and more static pages on the internet, and I think that a solution to this problem is to downgrade to Firefox ESR or older. (but don't got back to those really old versions like 10.0) The page with the different versions of Firefox is https://ftp.mozilla.org/pub/firefox/releases/ . I recommend scrolling down to Firefox 52.0 and installing that.

You also may need to load the plugins manually, so you can access that page at https://support.mozilla.org/en-US/kb/npapi-plugins

There is a totally simple explanation to this. I read an article on the Mozilla Support Page and it says that Firefox Quantum will no longer be supporting NPAPI plugins like Adobe Flash, Shockwave Flash, and Silverlight, because there are more and more static pages on the internet, and I think that a solution to this problem is to downgrade to Firefox ESR or older. (but don't got back to those really old versions like 10.0) The page with the different versions of Firefox is https://ftp.mozilla.org/pub/firefox/releases/ . I recommend scrolling down to Firefox 52.0 and installing that. You also may need to load the plugins manually, so you can access that page at https://support.mozilla.org/en-US/kb/npapi-plugins
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

chadfarneti said

Those opened in a tab. I will contact the affected servers to see if there is an issue on their end. I really appreciate all your effort.

If there is a public URL for a volunteer to test, we may be able to spot the reason that the PDF bypasses the viewer.


ThePriusMan said

I think that a solution to this problem is to downgrade to Firefox ESR or older.

Hi ThePriusMan, that may be what you want to do, but if you read the question again, it is about using the built-in PDF viewer and NOT about using Adobe Reader or the Adobe Acrobat plugin.

Also, if the server is sending a content-type other than application/pdf, or is sending content-disposition: attachment, then Firefox wouldn't use the plugin, either, it will always show the download dialog.

''chadfarneti [[#answer-1121911|said]]'' <blockquote> Those opened in a tab. I will contact the affected servers to see if there is an issue on their end. I really appreciate all your effort. </blockquote> If there is a public URL for a volunteer to test, we may be able to spot the reason that the PDF bypasses the viewer. ---- ''ThePriusMan [[#answer-1121915|said]]'' <blockquote> I think that a solution to this problem is to downgrade to Firefox ESR or older. </blockquote> Hi ThePriusMan, that may be what ''you'' want to do, but if you read the question again, it is about using the '''built-in PDF viewer''' and NOT about using Adobe Reader or the Adobe Acrobat plugin. Also, if the server is sending a content-type other than application/pdf, or is sending content-disposition: attachment, then Firefox wouldn't use the plugin, either, it will always show the download dialog.

Chosen Solution

I tried a few public sights and it seems to be working. The one I am having issue with is secure, so I will try to contact them directly. It must be an issue on their end.

I tried a few public sights and it seems to be working. The one I am having issue with is secure, so I will try to contact them directly. It must be an issue on their end.
James
  • Moderator
1598 solutions 11285 answers

ThePriusMan said

There is a totally simple explanation to this. I read an article on the Mozilla Support Page and it says that Firefox Quantum will no longer be supporting NPAPI plugins like Adobe Flash, Shockwave Flash, and Silverlight, because there are more and more static pages on the internet, and I think that a solution to this problem is to downgrade to Firefox ESR or older. (but don't got back to those really old versions like 10.0) The page with the different versions of Firefox is https://ftp.mozilla.org/pub/firefox/releases/ . I recommend scrolling down to Firefox 52.0 and installing that. You also may need to load the plugins manually, so you can access that page at https://support.mozilla.org/en-US/kb/npapi-plugins

You do not need to have any NPAPI Plugins in order to read that npapi-plugins kb article.

You misunderstood the article. Firefox 52.0 and later Releases (including the current 60.0.2) does not allow any NPAPI Plugins to run except for the Flash Player Plugin (old name Shockwave Flash) from Adobe.

The legacy Firefox 52 ESR does allow other NPAPI Plugins to run besides the Flash Player. However on Windows you need the 32-bit Firefox as the Win64 Firefox 52 ESR (and Releases from 42.0 to 51.0) only allowed the Flash Player and Silverlight Plugins to run.

Note the "Flash Player" (old name Shockwave Flash) and the "Shockwave (for director) Player" are two different Plugins. If it has Flash in the name then it is Flash Player.

Flash Player https://www.adobe.com/products/flashplayer.html

Shockwave (for director) Player https://www.adobe.com/products/shockwaveplayer.html

''ThePriusMan [[#answer-1121915|said]]'' <blockquote> There is a totally simple explanation to this. I read an article on the Mozilla Support Page and it says that Firefox Quantum '''will no longer be supporting NPAPI plugins like Adobe Flash, Shockwave Flash, and Silverlight''', because there are more and more static pages on the internet, and I think that a solution to this problem is to downgrade to Firefox ESR or older. (but don't got back to those really old versions like 10.0) The page with the different versions of Firefox is https://ftp.mozilla.org/pub/firefox/releases/ . I recommend scrolling down to Firefox 52.0 and installing that. You also may need to load the plugins manually, so you can access that page at https://support.mozilla.org/en-US/kb/npapi-plugins </blockquote> You do not need to have any NPAPI Plugins in order to read that npapi-plugins kb article. You misunderstood the article. Firefox '''52.0 and later Releases''' (including the current 60.0.2) '''does not allow any NPAPI Plugins to run except for the Flash Player Plugin''' (old name Shockwave Flash) from Adobe. The legacy Firefox '''52 ESR''' does allow other NPAPI Plugins to run besides the Flash Player. However on Windows you need the 32-bit Firefox as the Win64 Firefox 52 ESR (and Releases from 42.0 to 51.0) only allowed the Flash Player and Silverlight Plugins to run. Note the "Flash Player" (old name Shockwave Flash) and the "Shockwave (for director) Player" are two different Plugins. If it has Flash in the name then it is Flash Player. Flash Player https://www.adobe.com/products/flashplayer.html Shockwave (for director) Player https://www.adobe.com/products/shockwaveplayer.html
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

In case this comes up again, I created an extension that can help with this problem. I suggest leaving it off until you run into a problem, and only turning it on (using its toolbar button) while you are downloading files that need it. Otherwise, because it intercepts every response from every web server, it may slow down your browsing.

https://addons.mozilla.org/firefox/addon/content-type-fixer/

If anyone tries it, let me know how it goes.

In case this comes up again, I created an extension that can help with this problem. I suggest leaving it off until you run into a problem, and only turning it on (using its toolbar button) while you are downloading files that need it. Otherwise, because it intercepts every response from every web server, it may slow down your browsing. https://addons.mozilla.org/firefox/addon/content-type-fixer/ If anyone tries it, let me know how it goes.