Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox & Thunderbird have panels on all sides. How do I remove them?

  • 10 replies
  • 1 has this problem
  • 36 views
  • Last reply by James

more options

Both sides of the screen have panels with the same info (Window List, Bluetooth, Networks, Instant messaging, Vaults, Clipboard Contents, Volume, show hidden icons, and clock). I tried to delete these panels but could not. The top has a panel with the "application Menu Bar" which I need to save. I am using Kubuntu 18.04 , Firefox 60.0.1, Thunderbird 52.8.0. in 64 bit. Please help. This panel and info should just be at the bottom of the screen.

Chosen solution

I posted another wider panel next to the one I want to remove. I then went to more options in the wider panel (1 inch) and another wider panel appeared. in that panel options it had "remove Panel" When I clicked on it all the panels on that side disappeared.. I then did that same to the other sides and removed them all. Thanks to all that tried to help me. \

''''Problem Solved''''

Read this answer in context 👍 0

All Replies (10)

more options

Please show us what both programs look like.


In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

Here iis the screen shot. I hope this helps.

more options

The bottom is, of course, the computer's taskbar Those on either side, I don't know where they are from. I called for more help.

I don't know Linux, but aren't those also computer taskbars? Run your mouse over them.


Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

more options

I have downloaded the version suggested But must apologize. I am 86 and do not remember how to install from Ark. I have been just upgrading for years and memory fails me.

more options

Firefox for Linux comes as a tar.bz2 archive. All you have to do is to extract the files in the archive to a folder. This can be a folder in your home directory (/home/<user> or '~/firefox') or a folder in a location that requires root access (e.g. in /usr/local/firefox or in opt/firefox). If you use a folder in the home directory then you won't have a problem with updating (a folder with root access will require to start Firefox via sudo to give Firefox root permissions to be able to update).

See:

more options

I now have Firefox -60.0.1. I still have the Panels as shown in the screen shot I sent.

more options

Chosen Solution

I posted another wider panel next to the one I want to remove. I then went to more options in the wider panel (1 inch) and another wider panel appeared. in that panel options it had "remove Panel" When I clicked on it all the panels on that side disappeared.. I then did that same to the other sides and removed them all. Thanks to all that tried to help me. \

''''Problem Solved''''

Modified by reb68

more options

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

more options

reb68 said

I posted another wider panel next to the one I want to remove. I then went to more options in the wider panel (1 inch) and another wider panel appeared. in that panel options it had "remove Panel" When I clicked on it all the panels on that side disappeared.. I then did that same to the other sides and removed them all. Thanks to all that tried to help me.

As you found these are Panels in your KDE Plasma desktop manager and nothing to do with Firefox or Thunderbird.

https://userbase.kde.org/Plasma/Panels/en https://userbase.kde.org/Plasma#Panels

Maybe look for autohide option so any panels you have is not visible all the time and only when hover over with mouse pointer.


I use Xfce and I use two panels. The one of top is for OS stuff like temp sensors, network, cpu usage, hardrive usage etc. The one on bottom is for to show things like the windows of the applications I have open. I set the Panels to autohide so they take up no real space until hover over with mouse.

Modified by James