Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unsecure website connection error

  • 3 replies
  • 1 has this problem
  • 148 views
  • Last reply by Tonnes

more options

Hello, guys!

I have a problem, that is described in this article: https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER

But I decided to ask my question here because I've never had this trouble using usual version of Firefox, and when I've installed Firefox Developer Edition today, I got the trouble with "SEC_ERROR_UNKNOWN_ISSUER" when trying open any website. At the same time, my antivirus Kaspersky is annoyingly popping up attentions about this and asking to "ignore" or to "add to exclusions".

Actually, I've solved this trouble, when I disabled the interception of secure connections (as suggested in the article), but it is very questionable act due to security reasons.

I'd like to ask you to help me with solving the trouble in other way, which doesn't descrease security connection level.

Thank you very much for your time, Best Regards, Anthony

Chosen solution

Please trust the support article and refer to the 2 pages mentioned in this recent question, then reconsider whether or not there actually is a better solution.

http://www.cbc.ca/news/technology/antivirus-software-1.3668746 https://blog.vpn.ac/disable-https-scanning.html.

Note that you can still choose to keep it enabled after the issue turns out to be temporary for - in this case - Kaspersky.

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

Please trust the support article and refer to the 2 pages mentioned in this recent question, then reconsider whether or not there actually is a better solution.

http://www.cbc.ca/news/technology/antivirus-software-1.3668746 https://blog.vpn.ac/disable-https-scanning.html.

Note that you can still choose to keep it enabled after the issue turns out to be temporary for - in this case - Kaspersky.

more options

Okay, I get it. Looks like, the best solution is just to keep https scanning disabled in antivirus' settings.

Thank you very much, Tonnes. Have a nice day!

more options

Glad to help. Likewise!