Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Every time I open Firerfox, the Add-ons comes on. how do I stop this?

  • 4 replies
  • 1 has this problem
  • 5 views
  • Last reply by FredMcD

more options

every time I open Firefox the Add-ons manager appear in a tab of my address bar. How can I stop this?

All Replies (4)

more options

Hi, can try this : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 60.0.1 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

more options

Your Kaspersky Protection did this happen since you installed it or since it's update as per date on the Add-on Page ?

Can try this before the above please : SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

more options

Hi marinearty63, just in case it's something simple:

Firefox allows you to designate multiple tabs for your home page. Do you also get the Add-ons page in a new window (Ctrl+n) or when you click the home button (house icon)? In that case, definitely check the home page setting and see if it has something like this on the end:

https://www.mozilla.org/|about:addons

This article has more info on the home page setting: How to set the home page.

more options

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar. Type browser.startup.homepage

What is the value? Right-click and select Reset to restore its default value; about:home