Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

How can I turn off the annoying ctrl-Q shortcut?

  • 8 replies
  • 1 has this problem
  • 31 views
  • Last reply by juek

more options

Dear Developers,

I'm using Firefox v60.0.1 on Debian Linux. I was wondering why on Earth is the Ctrl-Q shortcut is defined at all to immediately close all tabs and quit the browser? I think it is an extremely bad idea to have this shortcut, since it is very easy to accidentally hit it by mistyping Ctrl-W, which is in turn oftentimes used.

I suggest to remove Ctrl-Q from future versions, or at least give the user the option to turn it off. In the current version I have found no way to do it, if there is, please let me know.

Many thanks in advance!

Dear Developers, I'm using Firefox v60.0.1 on Debian Linux. I was wondering why on Earth is the Ctrl-Q shortcut is defined at all to immediately close all tabs and quit the browser? I think it is an extremely bad idea to have this shortcut, since it is very easy to accidentally hit it by mistyping Ctrl-W, which is in turn oftentimes used. I suggest to remove Ctrl-Q from future versions, or at least give the user the option to turn it off. In the current version I have found no way to do it, if there is, please let me know. Many thanks in advance!

All Replies (8)

more options

Important Security Issue as thousands of problems, please remove your Flash 11.2 r202 https://helpx.adobe.com/flash-player/release-note/readme-flash-player-linux.html Flash Player Version: 29.0.0.171 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Unfortunately you can not change keys and that is what is mapped. But : https://addons.mozilla.org/en-US/firefox/addon/shortkeys/ I hope the above is workable for you.

Please let us know if this solved your issue or if need further assistance.

more options

The Menus and Keyboard/Mouse shortcuts on Linux is due to the Gnome HIG just as it is due to Apple HIG for Mac.

Linux and Mac have a similar shortcut for to Quit/Exit while Windows it is Ctrl + Shift + Q

https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly

The shortcuts have not changed much if any in so long.

more options

There were add-ons that could change hot-key settings, but whether the new Firefox can use them . . . . . .

more options

There is an extension to disable this key, but it doesn't work on Linux.

Bug 1325692 - [commands] Explicit support for overriding built-in keyboard shortcuts by WebExtensions

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

more options
Unfortunately you can not change keys and that is what is mapped. But : https://addons.mozilla.org/en-US/firefox/addon/shortkeys/ I hope the above is workable for you.

This add on you recommend does not solve the problem.

more options
Linux and Mac have a similar shortcut for to Quit/Exit while Windows it is Ctrl + Shift + Q

This does not solve the problem.

The shortcuts have not changed much if any in so long.

And has ever been an annoyance. This is a strange answer as it basically states that just because a problem exists for quite some time it would no longer be a problem.

This problem exists for a long time now. But as keyboards have changed this problem increased in importance. It needs to be fixed, it is extremely annoying.

Modified by juek

more options

@ juek (and anybody who might want to reply) :

You started your own thread here :

https://support.mozilla.org/en-US/questions/1239905

more options
You started your own thread here :

Yes of course. Otherwise I'm not even able to write a reply here. A conceptional design error of the support forum software.

Modified by juek