Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

showing secure connection on all websites

  • 6 replies
  • 2 have this problem
  • Last reply by myfireunfox

more options

all sites are showing "https" I think this is slowing my pc down even youtube while playing videos

All Replies (6)

more options

Hi, not the problem at all as all to most websites are now using HTTPS due to Google changes in ranking pages and displaying a banner in Chrome shaming people for not.

I would think that it is a few things and one of them is a older system with low ram and old video card with errors in the drivers ( as i see them). Please check : adapterDescription: Intel(R) HD Graphics 4000 driverDate: 8-21-2012

adapterDescription2: NVIDIA Quadro K1000M driverDate2: 11-5-2015

Please repair your system files and registry : please search for CMD.exe and when find in the list Right Click and Run as Administrator and Type : SFC /scannow ( SFC<space>/scannow ) Reboot after .

Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

If this fails to help please do a scan using these products please : and with If issues are found please go here :

You may want to think about moving to the Extended Release Version Firefox ESR does not come with the latest features but it has the latest security and stability fixes.

If do :

Optimize Windows 7 :

Please let us know if this solved your issue or if need further assistance.

more options

If it slows down website then make sure that your security software isn't scanning secure connection and acts as a man-in-the-middle.

See also:

more options

I tried more websites found a few that did come up http: and some https: did a speed test on my phone that gave me 8.2 mps on my PC same test gave me .87 mps.

more options

myfireunfox said

I tried more websites found a few that did come up http: and some https: did a speed test on my phone that gave me 8.2 mps on my PC same test gave me .87 mps.

Using wifi to connect to my phone hotspot running Norton on Lenovo W530 win 7.

more options

HI, please run these tools, It used to be Mr. Fix-it for Win 7 Find and fix problems with wireless and other network adapters Find and fix problems with connecting to the Internet or to websites Find and fix problems with incoming computer connections and Windows Firewall Find and fix problems to help optimize Windows speed and performance

Since is a Lenovo W530 Think Pad from 2012 you may really want to think about moving to the Extended Release Version.

If you need to determine the "Machine Type" and "Model" for you Lenovo laptop go to: Start->All Programs->Accessories->System Tools->System Information : "System Model". For Thinkpad Edge E530 the first 4 digits were the Machine Type, the last 3 digits were the Model.

Issues were fixed re connections by this old post : May want to look into it. Fixed it by updating the "Lenovo Fingerprint Read/Password Vault for Windows" driver and software

Go to your Lenovo CPU site and see if any updated drivers you have not installed.

more options

Thank you for all your help, I did run several of your performance improving suggestions that didn't hurt I'm sure.

Turns out my internet ISP was throttling my speed due to my plan limit. I'm so sorry that I did not see this first.

I am buying 8 more GB of memory and will install soon.

Thank you for your help!