Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

5 firefox memory hogging processes are running. How to reduce it to 1? (Win7 with 59.0.2)

  • 6 replies
  • 1 has this problem
  • 1 view
  • Last reply by Shadow110

more options

5 firefox memory hogging processes are running. How to reduce it to 1? (Win7 with 59.0.2)

5 firefox memory hogging processes are running. How to reduce it to 1? (Win7 with 59.0.2)

All Replies (6)

more options

More than one process is normal for the current Firefox.

Multi-process Firefox is codenamed "e10s".

Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

more options

You can try to modify multi-process settings to see if this has effect.

  • set number of content processes to 1 if it is currently set to a higher value (4)
    Options/Preferences -> General -> Performance
    remove checkmark: [ ] "Use recommended performance settings"

You can find the current multi-process state on the "Help -> Troubleshooting Information" (about:support) page.

  • "Help -> Troubleshooting Information" -> "Application Basics":
    Multiprocess Windows
    Web Content Processes
more options

Tried that config thing and it didn't help.

Harder now to know when it is going to crash. On my XP system Firefox would crash after it reached 1000MB in windows task manager. On this Win7 system it just froze at 5-6000MB. Having one process is easier to monitor.

Modified by paul90260

more options

Firefox shouldn't use that much memory.

Does the about:memory page show what is taking up that much memory?

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

On my XP I could keep 100 tabs "open" usually with no problem. If memory usage went high I would restart it. Now on this Win7 it's hanging at 5,000,000K

more options

Hi, XP and Win 7 are different things. So you brought the question up for Win 7. There is no need to talk about XP things as it work differntly. Also are you on the esr version as you should be on XP. Also end of life for Firefox on XP June.

Please try going to Options --> Privacy & Security --> Permissions and make sure there is a tick mark in the box to Prevent Accessibility Options from using your browser.

Optimize Win 7

Please think about moving to the Extended Release Version of Firefox for your low ram system'