Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My website builder on GoDaddy will not load since your last update.

  • 1 reply
  • 1 has this problem
  • 1 view
  • Last reply by FredMcD

more options

Since your last update when I try to load my temporary website to work on it in GoDaddy it goes to the page but the site won't load. Just sits there with the little circle in the middle going round and round. Everything works fine on Chrome and Explorer.

Just tried it again and now it won't even let me go to the editing page or show link to editing page. When I click on "Manage" for my site all it does is show me a page with the expiration date.

I hope you can get this fixed. I hate Chrome! Every time you try to go somewhere it takes you to an ad site or a popup blocks your menu bar.

All Replies (1)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Modified by FredMcD