Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Context3D not available! Possible reasons: wrong wmode or missing device support.

  • 6 replies
  • 1 has this problem
  • 139 views
  • Last reply by NolaGurl

more options

I play one game on Facebook called Coral Isle. When I click to play while on my HP Stream running Linux Mint, the game appears to fully load, but then the above error message appears.

I've seen reference to something called Nightly (no idea what that is) and another, more recent incident, but when I looked into the response didn't seem to apply. I followed what they said to do with putting 'about:support' and I searched for the same information about something failing, but didn't see anything similar. So I thought I'd ask again. I'm also going to send an email to the game's support to see if they can offer any help.

All Replies (6)

more options

Hi, suggest you reinstall your Video Card Drivers to clear up these errors : featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'unavailable',

Please let us know if this solved your issue or if need further assistance.

more options

Also please note current Firefox Version is 59.0.3

more options

In the past on window Context3D only worked with a 32-bit Firefox version. I don't know if this did (and still does) apply to Linux (I wouldn't expect this).

Did this ever worked on Linux?

more options

Need to figure out how to reinstall video card drivers. I'm really new at using Linux.

more options

Open about:config page and set dom.ipc.plugins.asyncdrawing.enabled = false.

more options

TyDraniu said

Open about:config page and set dom.ipc.plugins.asyncdrawing.enabled = false.

This didn't make a difference.