X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 57 and 58 were zippy for maybe six months, and now (sigh) 59 (edited subject)

Posted

After two months or so with Firefox 59 I'm now experiencing frequent enough to be regularly annoying hangs and freezes. My OSs haven't changed, my browsing habits haven't changed, and Firefox has changed.

As speed goes, the improvements of Firefox 58 were nice while they lasted. I'm back to 58 now, with no automatic updates, to see how things go.

Just feedback here for any listening developers.

After two months or so with Firefox 59 I'm now experiencing frequent enough to be regularly annoying hangs and freezes. My OSs haven't changed, my browsing habits haven't changed, and Firefox has changed. As speed goes, the improvements of Firefox 58 were nice while they lasted. I'm back to 58 now, with no automatic updates, to see how things go. Just feedback here for any listening developers.

Modified by makaio

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

calvinarchil 0 solutions 2 answers

Hi makaio, Have you tried booting Firefox in safe mode to see if your addons or settings are causing problems? If not, try following the instructions on this site. If your problems seem to be resolved, it is probably a problem with addons you have installed or your settings. In Firefox, go here and click on the blue button that says "Refresh Firefox", then "Refresh Firefox" again, then "Finish". Firefox will open up with default settings and addons reset. Your Firefox should speed up after that. ~calvinarchil

Hi makaio, Have you tried booting Firefox in safe mode to see if your addons or settings are causing problems? If not, try following the instructions on [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode?redirectlocale=en-US&redirectslug=Safe+Mode this site]. If your problems seem to be resolved, it is probably a problem with addons you have installed or your settings. In Firefox, go [https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings here] and click on the blue button that says "Refresh Firefox", then "Refresh Firefox" again, then "Finish". Firefox will open up with default settings and addons reset. Your Firefox should speed up after that. ~calvinarchil

Question owner

Thank you for the reply.

My add-ons (three extensions, two plug-ins) did not change between Firefox 58 and Firefox 59, so I would expect 59 to accommodate them as well as 58.

Furthermore I have no interest in losing all the menu settings and about:config settings I have made to combat Firefox's annoying defaults with regard to poor privacy and browser behavior.

I have gone back to 58 on two of three machines, and they seem to be performing better, although only a couple days have passed so far with regard to checking things out.

This machine still runs 59, and as a side note Firefox takes seemingly forever to open here, about two minutes.

As my subject notes, I believe the zippy days of 58 are gone. It was nice to have something to be pleasantly surprised about ... while it lasted.

This is a simple deduction based on the introduction of 59, and deduction is an anathema to software developers. I don't know why. Logic is the best thing since sliced bread to coders ... ... until the moment it is applied to the roll-out of their latest code, and then a generic flock of almost twenty-years old excuses take flight.

Thank you for the reply. My add-ons (three extensions, two plug-ins) did not change between Firefox 58 and Firefox 59, so I would expect 59 to accommodate them as well as 58. Furthermore I have no interest in losing all the menu settings and about:config settings I have made to combat Firefox's annoying defaults with regard to poor privacy and browser behavior. I have gone back to 58 on two of three machines, and they seem to be performing better, although only a couple days have passed so far with regard to checking things out. This machine still runs 59, and as a side note Firefox takes seemingly forever to open here, about two minutes. As my subject notes, I believe the zippy days of 58 are gone. It was nice to have something to be pleasantly surprised about ... while it lasted. This is a simple deduction based on the introduction of 59, and deduction is an anathema to software developers. I don't know why. Logic is the best thing since sliced bread to coders ... ... until the moment it is applied to the roll-out of their latest code, and then a generic flock of almost twenty-years old excuses take flight.
Shadow110 1072 solutions 14836 answers

HI, separate issue please update your Flash 27.0 r0 Flash Player Version: 29.0.0.140 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

You are not mentioning anything about excessive ram use but could you look please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

You can always do this and your Profile and settings are saved : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's(win10) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 59.0.3 with a Full Version Installer

fyi only : Now I do not advocate nor know results of doing this but Speedy Fox which is no longer a add-on/Extension has made a Windows program https://www.crystalidea.com/speedyfox

Please let us know if this solved your issue or if need further assistance.

HI, separate issue please update your Flash 27.0 r0 Flash Player Version: 29.0.0.140 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only> You are not mentioning anything about excessive ram use but could you look please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser. 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on. You can always do this and your Profile and settings are saved : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's(win10) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 59.0.3 with a Full Version Installer *https://www.mozilla.org/firefox/all/ fyi only : Now I do not advocate nor know results of doing this but Speedy Fox which is no longer a add-on/Extension has made a Windows program https://www.crystalidea.com/speedyfox Please let us know if this solved your issue or if need further assistance.

Question owner

Thank you for the reply,

I have corrected my subject, not knowing the exact timing of 57 and 58, but still knowing that with 59 the days of Firefox being reliable were short-lived. (All three pc's now running 58, and all three pc's now browsing with fewer hangs, etc.)

Constant updates, unreliable long-term performance, and constant troubleshooting -- this b.s. gets so incredibly old across all platforms.

I don't live to troubleshoot what paid developers don't bother to troubleshoot.

Vent complete. I'll try to look into your recommendations.

This b.s. gets so ... @#$%^&* ... old, Matthew

Thank you for the reply, I have corrected my subject, not knowing the exact timing of 57 and 58, but still knowing that with 59 the days of Firefox being reliable were short-lived. (All three pc's now running 58, and all three pc's now browsing with fewer hangs, etc.) Constant updates, unreliable long-term performance, and constant troubleshooting -- this b.s. gets so incredibly old across all platforms. I don't live to troubleshoot what paid developers don't bother to troubleshoot. Vent complete. I'll try to look into your recommendations. This b.s. gets so ... @#$%^&* ... old, Matthew
davidspriggs 3 solutions 67 answers

firefox 59 has treated me very goood, faster no hangs otr crashes andf i use it a lot with o problem.. dell all inone win 19

firefox 59 has treated me very goood, faster no hangs otr crashes andf i use it a lot with o problem.. dell all inone win 19