Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

very slow, uses all RAM

  • 5 replies
  • 1 has this problem
  • 264 views
  • Last reply by Neda

more options

windows 7 pro, firefox up to date, uses 97% of RAM after a few minutes with only two tabs open, will only close if forced

Chosen solution

A user.js file is reported in your profile folder. Check to see what software added it or the changes you applied there yourself, and temporarily run Firefox after moving it elsewhere. Is the performance similar?

And of course, check the performance in Firefox’s Safe Mode to see if one of your add-ons is causing the issue.

Read this answer in context 👍 1

All Replies (5)

more options

Chosen Solution

A user.js file is reported in your profile folder. Check to see what software added it or the changes you applied there yourself, and temporarily run Firefox after moving it elsewhere. Is the performance similar?

And of course, check the performance in Firefox’s Safe Mode to see if one of your add-ons is causing the issue.

more options

Note that you may have to reset prefs that are modified/set via user.js via the right-click context menu on the about:config page to the default value.

more options

Tonnes said

A user.js file is reported in your profile folder. Check to see what software added it or the changes you applied there yourself, and temporarily run Firefox after moving it elsewhere. Is the performance similar? And of course, check the performance in Firefox’s Safe Mode to see if one of your add-ons is causing the issue.

moved user.js file and reset firefox, which now seems to be acting more normally - didn't see a way to check what software added it and date was two years ago, so hard to understand why this was suddenly a problem, but happy it's happy now.

more options

cor-el said

Note that you may have to reset prefs that are modified/set via user.js via the right-click context menu on the about:config page to the default value.

thank you, I did this also, and happy to report success. This is an older desktop with only 4GB RAM, so as websites increase ad volume, places bigger burden on system, which may be part of the problem.

more options

Hi there! Anyone w/ the same problem?? After the latest Sep. 2018 update, FF fills the RAM to 3.5 G or more! (out of my 4 G). Only 4 tabs are open, no new thing w/ FF or my computer. Tried all the previous suggestions, no use. PC gets so slow that even mouse might not move! I don't have the user.js but deleted the java profile file and let FF make a new one, still the same! I updated Java and Flash, got a little better, but still something is wrong. Thanks

Modified by Neda