X
Tap here to go to the mobile version of the site.

Support Forum

High memory usage with 1 tab open, only 3 extensions and no themes installed

Posted

Currently I see about 330K - what, MB or KB? with only this 1 tab open. I see in task master that there are 5 instances of FF running. One of them has this origin: C:\$LogFile(NTFS Volume Log). Is this something I should worry about?

My laptop is kinda old and the fans are running a lot. Things calm down when I shut down Firefox. It doesn't, by the way, impact CPU usage that much, it says 1 CPU or 2. Of course, it does add up.

Is there any way I can tame Firefox's memory usage?

As far as extensions, I run Privacy Badger, HTTPS Everywhere, and Disable WRTC.

Thanks.

Currently I see about 330K - what, MB or KB? with only this 1 tab open. I see in task master that there are 5 instances of FF running. One of them has this origin: C:\$LogFile(NTFS Volume Log). Is this something I should worry about? My laptop is kinda old and the fans are running a lot. Things calm down when I shut down Firefox. It doesn't, by the way, impact CPU usage that much, it says 1 CPU or 2. Of course, it does add up. Is there any way I can tame Firefox's memory usage? As far as extensions, I run Privacy Badger, HTTPS Everywhere, and Disable WRTC. Thanks.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

What is in the running tab? Weblink? Ads and clips can use up a lot of CPU.


More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/

Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

What is in the running tab? Weblink? Ads and clips can use up a lot of CPU. ------------------ More than one process is normal for the current Firefox. http://www.ghacks.net/2016/07/22/multi-process-firefox/ Multi-process Firefox is codenamed "e10s". https://wiki.mozilla.org/Firefox/multiprocess Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the '''about:config''' page. '''browser.tabs.remote.autostart''' = false '''browser.tabs.remote.autostart.2''' = false Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''I Accept the Risk''' button. At the top of the screen is a search bar.
Shadow110 1072 solutions 14836 answers

Hi, you may want to switch to the Extended Release Version since is a older system : 52.7.3 ESR. It will continue to get security updates until June 2018, and you can download and install it from this page: *https://www.mozilla.org/en-US/firefox/organizations/all/ Note : Legacy Extensions will be deleted or removed in any version update after June 2018. Update Path : Firefox 52.9.0esr out on June 26 (same time as 60.1.0esr) will be the last major update for Firefox 52 ESR apart from any 52.9.x esr updates for security or allowed stability fixes.

Quantum Based Firefox 60.2.0esr will be out Aug 21 and Firefox 52 ESR will be EOL then. So people will have to upgrade to 60.2.0esr to keep getting security updates if they have not manually upgraded to 60.x.o ESR already. Firefox 60 ESR will require Windows 7, 8, 10.

You should make a backup of your Profile before going back and just because:

Or if wanting to continue with the release version : do this after backing up : Install Firefox 59.0.2 with a Full Version Installer over top to update you :

If still have issues : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Please let us know if this solved your issue or if need further assistance.

Hi, you may want to switch to the Extended Release Version since is a older system : 52.7.3 ESR. It will continue to get security updates until June 2018, and you can download and install it from this page: *https://www.mozilla.org/en-US/firefox/organizations/all/ <b>Note : Legacy Extensions will be deleted or removed in any version update after June 2018</b>. Update Path : Firefox 52.9.0esr out on June 26 (same time as 60.1.0esr) will be the last major update for Firefox 52 ESR apart from any 52.9.x esr updates for security or allowed stability fixes. Quantum Based Firefox 60.2.0esr will be out Aug 21 and Firefox 52 ESR will be EOL then. So people will have to upgrade to 60.2.0esr to keep getting security updates if they have not manually upgraded to 60.x.o ESR already. Firefox 60 ESR will require Windows 7, 8, 10. You should make a backup of your Profile before going back and just because: *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Or if wanting to continue with the release version : do this after backing up : Install Firefox 59.0.2 with a Full Version Installer over top to update you : *https://www.mozilla.org/firefox/all/ If still have issues : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser. Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on. Please let us know if this solved your issue or if need further assistance.