Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox randomly stops being able to open MOST websites, until reboot

more options

Fairly new laptop (had it ~ 3 months now) with Windows 10 (old laptop was Win 7)) and Firefox 52.7.3 (64-bit) ESR. Have had the problem since getting the laptop (and I keep it up to date with MS and FFX updates). Works fine for a while (can be several days) then suddenly can't open new web pages. However, some sites still work. (eg: hp.com - theregister.co.uk - amazon.co.uk won't open but bbc.co.uk - microsoft.com - mozilla.org will) Other browsers (IE and Edge) still work fine for all sites. Closing FFX and reopening doesn't help. Rebooting the laptop does clear the problem (until next time)

All Replies (12)

more options

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Let me know if this helps you.

more options

Thanks - will try that next time it happens (have just rebooted to clear it again!)

more options

Separate Security Issue: Update your Flash Player or remove it using these links; http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 29.0.0.140

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen or hold down the Shift key) to see if that has effect.


Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.


https://support.kaspersky.com/viruses/utility

See also:

more options

Update: Had the problem again - some sites still working (eg boredpanda.com this time) and some not (duckduckgo and lots of others) so tried the restart with addins disabled . Got the Mozilla Crash Reporter screen. I clicked the Tell Mozilla about this crash them Quite Firefox and started it back up - no web sites loading on any tabs (I have the "remember my open tabs" option set on) except the one that was open when the browser started (though the blue donut is still spinning on that and all other tabs) - it appears to show anything that was loaded but is not actually responding. Tried the restart with addins disabled - FFX crashed again. Started in Safe Mode using <Shift> click - Same again: initial tab loads the page, all other tabs sit with the donut spinning and a blank page. Just to check - all sites open fine in IE at this point. Rebooted laptop - all sites are coming up okay again. Have run the Adobe Flash update from https://get.adobe.com/flashplayer/ Will update again ...

more options

If you can't get Firefox to open, you will have to do this the hard way.

https://support.mozilla.org/en-US/kb/mozillacrashreporter Open the file browser / explorer on your computer. Note: You may have to enable Show Hidden Folders / Files. Enter this in the address bar;

Windows: %APPDATA%\Mozilla\Firefox\Crash Reports\submitted Win 7/Vista: C:\Users\<username>\AppData\Roaming\Mozilla\Firefox\Crash Reports\submitted Win XP/2000: C:\Documents and Settings\<username>\Application Data\Mozilla\Firefox\Crash Reports\submitted

Mac OS: /Users/<username>/Library/Application Support/Firefox/Crash Reports/submitted Linux: /home/<username>/.mozilla/firefox/Crash Reports/submitted

Copy the most recent 5-7 File Names in the folder. Post the information in the reply box.

more options

Thanks Fred, but I can get FFX to open - it's just that, once the problem appears, the only way to get responsive web sites is to reboot.

more options

We still need the crash report id's

more options

Most recent crash reports: - bp-6714a5a5-ca93-4fcc-919e-bb27b0180428 - 28/04/18 - bp-fec139d4-a378-43a8-9f2f-d2f711180302 - 020318 - bp-32682d66-77e1-4df9-adcd-7f59e1180301 - 01/03/18

Also, had the problem again this morning, after the Adobe Flash update (and I had restarted the browser after the update)

more options

Product Firefox Release Channel esr Version 52.7.3esr Build ID 20180322140748 OS Windows 10 OS Version 10.0.16299

bp-6714a5a5-ca93-4fcc-919e-bb27b0180428 Signature: shutdownhang | mozilla::net::ShutdownEvent::PostAndWait

amdihk64.dll = AMD DVR Component = Advanced Micro Devices, Inc

atidxx64.dll = Advanced Micro Devices = Check this link; http://support.amd.com/en-us/download/desktop?os=Windows+7+-+64

This is for Sumo's Related Bugs 1435343 NEW --- Crash in [@ mozilla::dom::workerinternals::RuntimeService:: CrashIfHanging]. Shutdown problem in workers. ++++++++++++++++++++++++++++++++++++++++++++++++++++++ Product Firefox Release Channel release Version 58.0.2 Build ID 20180206200532 OS Windows 10 OS Version 10.0.16299

bp-fec139d4-a378-43a8-9f2f-d2f711180302 bp-32682d66-77e1-4df9-adcd-7f59e1180301

Signature: shutdownhang | mozilla::net::detail::BlockingIOWatcher::WatchAndCancel

aswJsFlt.dll = avast!

This is for Sumo's Related Bugs 1435343 NEW --- Crash in [@ mozilla::dom::workerinternals::RuntimeService:: CrashIfHanging]. Shutdown problem in workers. ++++++++++++++++++++++++++++++++++++++++++++++++++++++ bp-32682d66-77e1-4df9-adcd-7f59e1180301

Signature: shutdownhang | mozilla::net::detail::BlockingIOWatcher::WatchAndCancel

tv_x64.dll = TeamViewer

This is for Sumo's Related Bugs 1435343 NEW --- Crash in [@ mozilla::dom::workerinternals::RuntimeService:: CrashIfHanging]. Shutdown problem in workers.

more options

Were you using Firefox Version 58.0.2 and then decided to use FF Version 52.7.3esr ?

Check TeamViewer for updates.

Check avast! for updates.

more options

Did you also try with a fresh profile?