Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Is there a known issue for the GUI not displaying pages correctly, in some cases I get like a split, and the two parts disply in the wrong order.

  • 5 replies
  • 1 has this problem
  • 34 views
  • Last reply by FredMcD

more options

I have taken some screenshots to show what I look at every time I update to a version 57+ I did try updated versions as they became available, in case my problem had been fixed, but it gets so annoying that I roll back again.

The Image upload feature doesn't appear to be working here so I uploaded some screen grabs to Imgur.

Only displaying part of the page: https://i.imgur.com/9gsgekO.png https://i.imgur.com/FfwLP6b.png

Images and other page details disappear: https://i.imgur.com/s7W7Seg.png

Pages are split and do not display in one piece: https://i.imgur.com/l8FPFdF.png

It's not my graphics drivers or anything else, everything is up to date. I roll back to 56.0.2 (32-bit) and this solves the issue. I am having the same problems on two machines running Win7. Cheers, Keith

Windows 7 Home Premium 32-bit SP1 Intel Core i5 4440 @ 3.10GHz 47 °C Haswell 22nm Technology RAM 16.0GB Single-Channel DDR3 @ 666MHz (9-9-9-24) Motherboard ASRock B85M Pro4 (CPUSocket) 38 °C Graphics: C27F390 (1920x1080@59Hz) C27F390 (1920x1080@59Hz) Intel HD Graphics 4600 (ASRock) 2048MB ATI AMD Radeon R7 370 Series (ASUStek Computer Inc) 46 °C CrossFire Disabled

Chosen solution

A link to some of the bad web pages.

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}


Separate Security Issue: Update your Flash Player or remove it using these links; http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 29.0.0.140

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Read this answer in context 👍 0

All Replies (5)

more options

Please provide public link(s) (no password) that we can check out. No Personal Information Please !


Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

more options

Gidday, Fred, thanks for your quick response.

What do you need a public link to? Images?

I updated to the latest version, and the issue reappeared on about the fifth page that I opened, so I didn't muck about, I rolled back again. I don't think it's tracking protection, I didn't see a shield but I admit to not looking for one - The pages are displayed in an incorrect manner, things in the wrong places rather than being blocked. It doesn't happen on every page, but once it has happened it seems to get more common, it gets worse the longer I stay online - which suggests some kind of cache problem, or memory issue, no? Even after a reboot it doesn't fix it, and it has happened on more than one version of 57+. When I roll back to 56.0.2 the issue is not there, so I can't see how it can be any problem with my machine. Does the new version like Windows 7? Keith

more options

Chosen Solution

A link to some of the bad web pages.

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}


Separate Security Issue: Update your Flash Player or remove it using these links; http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 29.0.0.140

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

I updated one of the computers and it seemed to work OK. The newest version is not the one I was having the issues with.

I will stay on the new version unless I get problems again.

Thanks for all your time and trouble, Fred

more options

Hopefully, it will stay fixed. Safe surfing.